Devices tab tiles issue on Android

When I turn a device on or off in the devices tab in the Android RC, the shape of the device flashes green.

Is that normal, and if so, what is it indicating?

1 Like

When you have a chance, could you please share the following details:

  • Mobile Device make and model
  • Operating system and current version
  • Hubitat Mobile app version and build number (from "Settings" tab in the mobile app then select "Show Debug Information")
  • model of device (and driver used) that is flashing green.

Samsung Galaxy S20+ SM-G986W
Android 11 with June security patch
Version says 1.6.1, but I swear its been showing that for a while.
Updated to the release candidate last night.

1 Like

Flashing green is a transitional state while the command is being executed and the new state is updated in the mobile app. Mind sharing what device is, and what driver type it uses?

Mine does this too.

I think that just shows what the last device you pressed was, or that the device is in the process of changing. Sort of like the working symbol in windows.

I've noticed the same on occasion, with various devices/drivers (one I can call out is the built-in zwave switch driver) - hitting my Android "back" button reloads the screen (and I'm guessing explicitly polls the hub) and it shows the correct state. Seems periodically an event is missed from the Hub to stop this "transitional" effect and update with the proper state

It's a fairly recently released Ikea Tradfri bulb.

TRADFRI bulb E12 WS 450lm
Advanced Zigbee CT Bulb

Mobile Device make and model: Samsung Galaxy s10 5G

Operating system and current version: Android 11, Jun Update

Hubitat Mobile app version (from "Settings" tab in the mobile app): 1.6.1

Device: Lightify Bridge Integration > (2) CCT: A19 Adj TW 02 Blubs

Group: Family room

Groups and Scenes: Movie Lights = Family room Groug (5%) brightness = R/L bulb (devices) on/off 5%

Issue:
Feature/Function: Device tab in the Hubitat Mobile
If I select movie lights, they turn on and off without issue.
If I select family lights, they turn on and off without issue and I can change the brightness without issue.
If I select individual lightbulbs, they turn on and off without issue, but I can change the brightness the mobile application crashes.


Not issue with this from the Mobile application with the dashboard. Only through the Device tab.
In addition, feedback is sometimes not correct lights could show on when off or the other way around. (Device, group, Groups and Scenes). Close and reopen and it reports correctly again.

Feature/Function: Widgets Hubitat Mobile
I have put them on the home screen but NONE of them work. They will not turn on or off anything.

Long press on device, brings up slider to adust brightness

Correct but when you move the sider for the brightness it crashes the mobile application.
Not Only on the individual Bulbs.

Mind sharing the build number (go to Settings then click Show Debug Information)

Build: 113

1 Like

After the firmware update today. It still broken but the symptoms are different. Before the movie lights worked without issue; not they don't work.

Can you log out and back in (go to Settings tab, then click on the hub).

I recreated the scenes on the it is working right now. Odd think if I operated V-Device from a browser (computer) it looked like it worked. When I did through the App (device Tab) it didn't or from tools from the embedded browser it didn't. Strange... At least I'm back where I had started. :slight_smile:

1 Like

I wasn't able to reproduce the crash. But I was able to reproduce the prolonged transitional state on colored bulbs and escalated to engineers. If the app crashes, please be sure to submit logs in Google Play so that engineers can figure out why it crashes.

So, I did today. But typical it doesn't give the options and it just closes out the application. This was the first time at allowed me to do that.

I'm trying to reproduce it and I can consistently but to submit a crash doesn't come up.

FYI.. I have tried the widgets again BLANK.. nothing at all.

Have you logged out and back in?

Yes I did.

Download the Hubitat app