Devices present in Devices list missing on Zwave mesh

C-7 hub

I have a ZWave device I added and was working for some while then disappeared from the ZWave Details page and no longer appears on the ZWave map. However the device is still present in the Devices list. It's assigned an ID in the Devices list but that ID does not appear in the ZWave mesh (anymore).

The device status updates in real time if you manually operate the device, but the Devices entry cannot control the device.

The ZWave mesh is missing 7 devices in total that used to be present and are still present in the Devices List.

What's the best process to effect repair?

Shut down the hub and remove power for 10 seconds then reboot. See if that makes a difference.

1 Like

Tried that and no change in condition or situation.

Do you have hub protect with cloud backups? You could restore the most recent backup along with the zwave radio.

It sounds like the devices were not excluded, they are still sending updates to the hub. Seems like maybe the database on the zwave radio itself got corrupted somehow. Very stange indeed.

@bobbyD @bcopeland Do you want to look at this or any other ideas?

As a last resort, you could rename the DNI on effected devices, just add something to the end like _OLD. Then exclude, following by include on each device effected. Use swap apps to swap app your app links from old device to new device. Then force delete the old orphaned device entries.

1 Like

I did not have a current backup.

My steps:

  • attempted to exclude all lost devices
  • factory reset any devices that would not exclude
  • deleted ghost Z-Wave devices (those in the Device list but not in the Z-Wave Details)
  • (re)add each excluded/reset device

I then created a local backup for future use.

The only remaining artifact is a inverse ghost device that is in the Z-Wave table but not in the Devices list:

  • 0x12 (018) PER: 0, RTT Avg: ms, LWR RSSI: N/A
  • Neighbors: 1, Route Changes: 0 RefreshRepair

It has no route assigned to it.

Sounds like a dead node, since it has 1 neighbor you should be able to remove it easily by doing a refresh, wait for page to reload, then you should have a remove button, click remove (once). Hopefully it will just go away after that. You can watch the live logs for errors / feedback.

1 Like

I did the refresh, then the remove and it did not go away.

From the Logs:
[sys:1] 2024-01-11 03:48:10.299 PM [info] Failed node 12 remove status: no reply
[sys:1] 2024-01-11 03:49:08.789 PM[info] Failed node 12 remove status: 0 SDK failure node is no longer in failed node list
[sys:1] 2024-01-11 03:48:00.304 PM [warn] Z-Wave Network responded with Busy message.

Sometimes if you shut down the hub and remove power for 10 seconds, then restart, that will help it work. There are a bunch of tips and trick in this post: How To: Remove Z-Wave Ghosts (including using a UZB Stick)

Its also probably not hurting anything but still annoying yo have in there.

1 Like

If you have figured out who the one neighbor of the ghost is and you exclude, reset, and then (re)include the neighbor device, would that in effect clear the ghost?

I was able to use the "Hubitat Z-Wave Mesh Details" to discover who the ghost's neighbor is.

0x09 is a valid, working Z-Wave device

Side note: the UZB stick is on order.

It would not clear it, but should allow you to remove it. It has been found that if any neighbors (other than the hub) are present then the Z-wave SDK refuses to remove the node :frowning: . Usually when there is only 1 neighbor left it is the Hub, so this is a new one. I guess not every device can see the hub as a neighbor if it is on the outer edges of the mesh.

FYI - A local backup does not back up the zwave radio data; just the database.

Status update:

1: Tried to exclude the one neighbor (9) of the failed node (12). Ran into complications and the device (9) failed to exclude after several attempts and basically required a factory reset.
2: I now have two ghosts, (9) has three neighbors and (12) still has one neighbor.
3: received UZB stick (Zooz 800)
4: Was able to cleanly remove (12) using PC Controller
5: Attempt to Is Failed, Remove Failed (9) using PC Controller and the Zooz stick goes into a dirty non-responsive state.
6: Reset Zooz UZB power and firmware (via PC Controller), clean up leftover Zooz device in Hubitat (Refresh, Remove in Z-Wave Details)
7: Include Zooz (again) and attempt Is Failed, Remove Failed cycle on (9) until Zooz goes back into dirty non responsive state
8: goto 6

I still have a ghost Z-Wave device (9) with three neighbors that will not die. I have shutdown and restarted the C-7 controller between each major failure or Network Busy error.

I eventually got was was device 9 to reset and excluding it fresh does nothing. Including it now creates a whole new device in the Z-Wave network which I have since excluded.

Data point:
When using the Hubiutat built-in Remove (Z-Wave Details), I see the following in the Logs:

[sys:1] 2024-01-16 02:32:37.432 PM [info] Failed node 09 remove status: 0 SDK failure node is no longer in failed node list

Yeah thats the usual BS error from the SDK when there are any neighbors listed for the device still.

Not clue why it wont remove from PC Controller, thats a new one.

Not only won't it (9) remove but it "blows up" the UZB stick. The only resolution for the "dead" stick (in more detail):

1: Unplug and replug Zooz UZB 800 UZB stick
2: Restart PC Controller software
3: Highlight UZB controller and press Reset in PC Controller -> Network Management
4: In Hubitat, ZWave Details, Refresh UZB controller device
5: In Hubitat press Remove on UZB controller device

Also once the UZB stick goes into the dirty state you cannot get it to exclude on its own. It will only respond to the Reset command and then only after a replug (power cycle).

Once the UZB stick is dead/dirty/non-responsive and then reset, it appears as a whole new device in PC Controller (new local ID) and when being included the next time (new Hubitat ID).

There is no physical reset button for the UZB stick, at least not on the Zooz 800. I assume it's similar for other UZB sticks.

Are you pairing the USB stick with security or None? I usually pair mine with the default which is S2 Access Control and it then gives a DSK to put it on the hub side. I dont think it is needed to just remove a ghost node, but might be worth a try?

I have been pairing the UZB without security as per the instructions. I'll try it with security. Am just going through my next test and reseting the UZB stick. I got the ghost device down to two neighbors by excluding one of the three neighbors.

I am beginning to thing the pain point may be that one of the remaining neighbors is a battery powered lock device? Probably the most painful device I have to exclude and re-include since it will mean dissecting the lock to get the original programming code, resetting it and reprogramming personal lock pins. I was hoping to not have to do a rain dance.

If you can get the PC Controller to cooperate with the stick, it should be able to be removed with the neighbors. It is only the Hub that suffers from this issue, supposedly something with the current SDK from SiLabs.

Unfortunately using S2 did not change anything. Here are the PC Controller Logs:


A few extra details:

  • After the first attempt to perform a Remove Failed, the UZB is dirty, and for all practical points and purposes dead, even if it appears to respond to PC Controller commands. If you keep trying to perform other commands, eventually it will quit even appearing to respond.

  • To clean up, I left out earlier, that after the (dead) UZB Refresh and Remove in Hubitat Z-Wave Details, you also have to go into the UZB device under Devices and click Remove Device to complete the total cleanup.

Closing the loop...

Ghost 9 had two remaining neighbors, the lock and a switch. I decided to exclude the switch, after which I was able to reclaim the ghost using the UZB stick and PC Controller. Apparently I needed to knock it down to only one neighbor to make it go quietly. The network is ghost free... for now.

1 Like