Device wont turn on in a rule but will manually


#1

I have a Simple Lighting rule that turns on a bookshelf light (it's a Aeotec microswitch). This simple lighting rule worked well for 6 months but recently all devices in that rule turn on except the bookshelf. If I go into the device I can manually turn it on an off so it IS functioning.

Any tips? Has a firmware update done this? Others experiencing this?


#2

I have this issue this morning on some Hue bulbs triggered by motion not turning on as they should, but working fine through device manually. Only change is updated to new firmware right before bed last night. Also, my times in 'Events' are off by 3 hours. Still fiddling with mine.


#3

Check your logs and post them with any errors. It will be a good place to begin.


#4

I think my problem is me, not the rule :man_shrugging:. Forgot a have a sunrise -30 time constraint on the rule and that is what is causing the lights not to come on.

Still not understanding the time difference in 'Events'. Log shows correct times, but Events time is off. Never really noticed this before, so might have been like this all along. Still early here (Florida 6:59 AM as I type this) and I haven't had any coffee yet, so that may be the issue :wink:


#5

no errors in my log but I can't see it being attempted. I just see it showing:

dev:742019-06-09 19:00:30.858 infoLounge Bookshelf Lights Micro Switch is off [physical]

dev:742019-06-09 19:00:30.724 infoLounge Bookshelf Lights Micro Switch is off [digital]

dev:742019-06-09 18:09:15.044 infoLounge Bookshelf Lights Micro Switch is off [digital]


#6

Fixed this by deleting the rule and recreating it exactly as it was. Not the first time this has happened.