Device discovery broken after update

Trying to install my new thermostat, went to go pair it and saw there was an update so I took care of that first. Now this is all that's on my device discovery page. I tried rebooting, no change. I haven't noticed anything else wrong. Is it possible to reinstall the firmware?

1 Like

I read that Support has seen this from some users, and their suggestion was to clear your browser's cache (they didn't say, but it's possible that a "full" refresh as Shift+Refresh, depending on browser, may do too). You could also try private/incognito mode if you don't want to do that or want to test ahead of time whether that's likely to work.

You can't directly reinstall the current firmware version, but you can downgrade and then re-upgrade if you prefer (so effectively doing the same) via the hub's Diagnostic Tool if you wanted. However, I don't think that should be needed here.

Good luck!


Hey, that did the trick! I had already found where I could roll back the firmware and tried it to no avail. Guess it was my stupid browser.


This is an important lesson. I’ve experienced many occasions where it seemed like the hub was completely unresponsive. Closed the tab and opened a new one, and the hub was not actually unresponsive at all.

Just updated to and when I go to discover devices I get a blank white box. Anyone else seeing this happen?

There are a couple of threads about this.
Here's one.