Device Attribute 3.2.1.141

I had an application setup and working; plus, the rule that worked, for what I needed it to do. I removed the application by accident. I setup the application and fix the rule. (RM).

So, now when I go into the rule to configure it again for the output device attribute to be set as a variable the attribute is no longer listed. (Note this did work because I was able to do it initially)
I’m looking for Index (whatever) as you can see in the driver attribute is listed in the driver details, but not when I go into RM. This does work if I use something like Webcor. It sees the device Attribute.

However, if I use a Trigger, I have that attribute listed. This isn't the only driver that does this too.
Please, correct me if I'm wrong All device attributes should be visible both for Trigger and for rule setup.

RULE


Driver

Trigger with in the Rule.

Thank you for your help.

I think one of your screenshots was supposed to be the device detail page, showing the attrbute, rather than the rule (again). But you can probably get some help without that.

Here's my guess: what type of variable is this, and what is the type of the attribute? If they are not a good match, RM may not display them when choosing. Look at the driver code, or try a different type of variable.

1 Like

Thanks for the reply. I copied the wrong image.

Basically, the driver is requesting information from (in this case a site) location about an attribute (indextoday) and I want to get that value to and variable. I don't know how else; I can do that. I can mess around with WebCore Expressions but I'm not Expressions with in WebCore. Some things are easier in RM (like this) and other things are much easier in WebCore. Plus, I have another application that is doing the same thing. Although, the same developer develops it. The odd thing is I has this working with out issue now I cannot see it. It did work.

Assuming it's still not working for you (maybe there's a typo in your second-to-last sentence, because I'm still not clear on that?), this information would still be relevant to know:

If you do not know how to inspect the driver code yourself, a link to it so that other people can take a look would be helpful. You could also see if another variable type works. Decimal looks like a logical choice, unless the driver happens to be (oddly...) reporting this as a string. Number probably won't work because that expects integers.

Sorry. This did work at one time. Way back, wheh I had set this up.

So we are back to this. :slight_smile:

1 Like

I believe this is what you are asking for. (Current Value aren't correct because I just selected what this time around). However, this is the original config of the variables.

I'm testing the Decimal Variable. I did this originally and it didn't work right. That's why I used Sting.
Was giving me a null value when I did this like 2 years go.

image

This looks better. I 'm going to clean this up and see. Thank you for your help.

Thank you for your help. I think I have gotten it.

1 Like

Download the Hubitat app