[DEPRECATED] Kasa Plug, Switch, and Bulb integration

Trying to install a KP405 outdoor dimmer. The device is found but won't install. Any clues?

Need logs to have a clue. But make sure you have installed the dimmer driver.

1 Like

@djgutheinz I have a Kasa KP105 smart switch which is currently offline (dropped off my WiFi) and the Kasa iOS app correctly shows it as offline. However the device page in Hubitat for the same device still shows it as connected with on comms errors. It has now been offline for about 10hrs, should the Hubitat device status show a connection fault?

Comms Error. try running save preferences the refresh a few time. It may have stopped the refresh log. Connection will not change unless you change the connection.

Missed the dimmer driver install, thanks!!!

1 Like

I have deprecated this integration at the current version. Alternatives:

Legacy Kasa Devices. These are the non-Matter Kasa Devices except for the Kasa Hub 100. New installations should be via the built-in integration.

Matter Kasa Devices and Kasa Hub. Two options:


Did the migration issue from the community version to built in version get resolved?



Note, earlier versions of the built in version had a migrate function. It had a flaw that caused the migrated children to be orphaned from the app on the next Hub reboot. This caused issues if the IP address changed (i.e., the user did not read the instructions).

Later versions have deleted the migration function in the app. Current version of the legacy drivers have Manual IP and Manual Port preferences to account for the orphaned children.

Regardless of the answer to this question, the deprecated version will continue to work for existing installations / devices. Just no future functionality upgrades. I will attempt to fix any critical errors - but the primary fix will be to go to the built-in version.

I just no longer have the personal bandwidth to handle this and living my 75 year old life.


My only reason for asking was to dictate which path I choose to move to the integrated version. Either way was fine with me.

I completely understand not wanting to maintain 2 versions of the same code.

1 Like

I 100% understand you not wanting to maintain the deprecated one, and appreciate all you've done for us! I do have a question, is there a recommended method to migrating from the deprecated to the built in? Do I just delete the community one and then install the builtin and then fix all my broken automations? Is there an easier way I am unaware of that results in the least amount of re-work?

1 Like

There is no easier way; however, there is also little advantage in changing over.

Ok thanks. I appreciate the information.

1 Like

I have started to get the following error on multiple KASA devices... Any advise?
"NullPointerException: null on line 626 (method parseUdp)"

1 Like

Run the app to reset the IP addresses. It looks like you did not set static IP (DHCP reservations) for your devices.

How do I reset the device database in the current tool? I can't find that option in the current iteration of the tool.

Originally I had about 6 device integrated using the custom app but for some reason when I added a new device the app wouldn't find it. So I deleted the custom app and used the built-in app and the app found only the new device but not the old devices!

Delete the custom app.

I did that already. I even removed the code from the repository. I've deleted the built-in app as well but I am still having the same difficulty.

If you have removed ALL instances of the built-in and Community app and then tried again, it may be indicative you have a orphaned device still in your device list. Check there.

Other possibilities:

  1. Devices are not all on the same LAN segment (i.e., 193.168.50). If not, the install will not see the device list to install in the app. Other LAN security issues can also cause issues.

  2. Device driver is not present. It would be on the list to install; however, an error would be thrown and the device will not install.

  3. There is another device with the same DNI within the same Hubitat Hub. Device would be offered for install, but an error would be thrown.

  4. Last ditch work around. Read the instructions and maybe try a CLOUD install for the missing device.

DO NOT use the Community APP. The built-in app is easier to install (no code to install) and has the exact same functions.

Thanks for all of the support. I figured it out. Eero apparently by default use a subnet that spans two LAN segments (.4 &.5) and the other devices were on the other LAN segment. It previously worked fine when I had a C-7 because it was assigned an IP address on the same segment of the old devices but since upgrading to a C-8 the hub was assigned an IP on the other segment and that is why it couldn't find them. Defining the LAN segment fixed the issue.

1 Like