[DEPRECATED] Echo Speaks

I just refreshed my cookie and it seemed to have worked fine. I also did a test to my bedroom echo and that worked as well:

UPDATE: My info may be off. I tried refreshing the cooking a couple of times and while the logs show current time, the app shows yesterday:


Mine previously showed June 13. Now It shows nothing because I can't get it to refresh. The login page just keeps looping every time I enter my username and password.


Yup same date for me


After logging the page states "Amazon Alexa Cookie Retired Successfully", but then comes back to the login page as if it was not logged in.

Mine also.

It finally broke this morning. When I went to the amazon login page, I needed to complete a two factor authentication (it sent a 6 digit number to my cell phone).

Ever since I installed Echo Speaks about a month ago, it only works intermittently. At first it will successfully speak my message. After a few times, it will stop speaking. When I try it a day or two later, again the same pattern. It works at first, then stops working. I do not see any errors in the logs, but I do see a debug. I’m not sure if the display of debug in the log indicates a problem or not.

Echo Speaks is being called from within a rule, and the rule is executing perfectly except my message is not spoken after the first time, or after the first several times. Within the rule I have at least a 30 second delay between messages.

I’m on version 2.5 of Echo Speaks.

Any help would be appreciated

I am still down and unable to login to Amazon and generate a new cookie. Anyone else have any success?

Still down.

I was wondering how long it would take Amazon to change something and break this.

Hopefully @tonesto7 can figure out the work around. There are also lots of communities that have used this method to integrate. I bet there are some smart people already poking at it.

Not sure where you're all located but I'm in the UK and have not had any issues....yet! (kiss of death)
I've had occasional errors in the past and a device become unresponsive a couple of times, but all ok since 2.5
Possibly region specific?

There are people on the SmartThings Community forums that are in the UK with issues.

Ping @tonesto7

I’m also UK and it’s down for me :disappointed_relieved:

It is likely just a matter of a bit of time before everyone's cookies expire...

I'm not sure why the cookies are now failing but if you're looking for a short term fix, you can manually enter the cookie and that seemed to fix it for me.

  • Open your echo speaks app
  • Click "Login Service Settings"
  • Click "Heroku App Settings"
  • In the Heroku pop-up, click "Open App" (at top)
  • In the new page that is opened, there should be a button to manually enter a cookie.
  • Follow steps here to get that info and enter it.

Mine seems to be working ok after that.

1 Like

wow... i try to take a couple days off work and relax with the family and shit hits the fan :crazy_face:
i need everyone to relax and let me try to catch up...


i’m pretty sure this is related to the UK only for the moment. i’m in the US and token refresh is working for me.

I didn’t write the module used for the cookie collection and refresh. I have worked with Apollon77 on a couple issues in the past so we have a decent rapport...
the module used to handle the logon cookie process is GitHub - Apollon77/alexa-cookie: Library to generate a cookie including a csrf for alexa remote

I just modified to work with UI and run under heroku.

Token refresh is not working for me and I use amazon.com

All I get is loop to get a new token using the Heroku login screen. Try a manual cookie doesn't work either.

1 Like

I’m in the US too and it failed for me.