Dashboards don't appear in the iOS app

Hi there,

I swear I've seen this problem before somewhere on this forum but I can't find the thread anymore. Anyway, I have a HE with a really simple dash with a few widgets on it and I want to make it available in the iOS app. When I view the dashboards I can see its name, but when I select it I get nothing but a white screen. This happens on both my iPhone (an iPhone 11 Pro running 15.0.2) and my partner's iPhone (an iPhone 7 also running iOS 15.something). Both are running the latest iOS client on the app store.

What I've also noticed is that I cannot open the Cloud URL to the dashboard on my phone nor my laptop, but the local LAN URL works okay. "Allow access to this dashboardvia remote/cloud links" is enabled under the dashboards advanced settings. I've also tried creating a whole new dashboard and get the same thing. Can anyone suggest what this could be?

Another thing - if I go to Tools>Notitications quite often the app says I have an invalid token (though now it's not doing it...grr). Would htat have anything to do with it?

Hello Everyone. I'm a newbie to Hubitat, I finally had enough with Wink. I just got my new H-7 and have managed to move most of my devices over. A bit of a learning curve, but i'm getting there.
I am having the same problem with the App not displaying Dashboards on the Dashboard Tab. The only way i can view Dashboards is by going to the Tool Tab then Connect using Remote Admin then selecting dashboards. The dashboards work as designed once selected. I can also get to them buy going to Find Hubs, then select my hub then dashboards. If i go straight to the Dashboard tab i get a white screen with a loading circle that never end or loads anything.
Please help, i have tried everything i can find on here but still can fix it. Thank you.

SOLVED: I figured this out late last night. I went into the iPhone app and under Settings the Enable Custom Dashboard was turned on. I turned this feature off, as I don't use a custom dashboard and boom, my dashboards show up right away on the Dashboards Tab.

It looks like when the custom dashboard switch was enabled and there was no URL entered, the menu does not know where to go. make total sense to me. I hope this help somebody else.
Thank You!


Well spotted and thanks for posting so others can benefit from what you found.

@bobbyD - Thought you guys might be interested, if only so you were aware of it, or in case you wanted to include something to catch this missing setup or provide some feedback to the user in the app.


Thank you, @cordoza

I had the same issue. Seems to be resolved! :smile:

1 Like

Hey, thanks! I was having this same issue, where my dashboard would not load remotely and this solved my issue. I was a little disappointed to lose the Custom Dashboard feature though, to take me directly to a certain Dashboard instead of the list.

Now, I hope I can help you, or someone else out. It looks like you just need to use the Cloud link instead of the Local link, in the Custom Dashboard field (in settings). I have tested it a few times and it appears to be working, when I switch my phone to cellular (i.e. remote). You can get the cloud link very easily by going to the dashboard settings page (in the Apps tab) and then selecting the dashboard and scrolling down the page. You will see two links for Local and Cloud.

Download the Hubitat app