Dashboard Tile not saving/changing color for the state

I couldn't see the posted by anyone else, so forgive me if it is & I am duplicating. New to Hubitat, creating a first serious dashboard. Background color on my tiles is to changing when something gets turned of/on, or status changes. When I go to dashboard template and try to assign a custom color for a device, say 'shade' or thermostat, it's not enabling 'save' button for me to save. I have tried this on two different dashboards, same issue. See the screenshot.


What browser are you using? It looks like you have saved the Red color change. What happens when you click remove? I just tried it on Chrome and Firefox and I was able to change in remove the change. If you are using Edge, try one of the above browsers and see what happens.

EDIT: Also the "save button" doesn't change, you just have to leap of faith it. I click it (and the CSS save button) twice because they do not seem to "react". However when I close the window 99% of the time the changes did save.

Something to keep in mind, when making changes the new CSS is appended to what is currently loaded when pressing save, at times that makes it so that it doesn't work without a full window refresh. This may not be the reason here, but it may be something to keep in mind.

I was initially using Safari but then moved to Chrome. Same symptoms and issue on both. It doesn't save or change. Been hitting save a few times.

@marcus has a point, make sure you do a page refresh as well to be certain.

You color template for Shade "closed" has changed to Red. You were able to set it that way at some point, so your save button must work. Normally there would be no color there as default is blank.

When you click the "Remove" what happens?

When you click "Remove This State" what happens?

If you click the Red color pallet can you change it to Blue and save?

Sorry to have more questions than answers, but it is not adding up. I could also give you CSS to make color changes, but you should not have to do it that way. Please let me know what happens when you do the above and we'll see if we can get to the bottom of this.

@TechMedX I feel I am not following some basic first obvious step and doing something childishly silly. Best way would be to show it, so I screen grabbed the whole interaction. When you see me pausing over 'save' for sec or so, that's me hitting save like a madman. Sorry for awkward pause at about 1:29 mark, that was me trying to refresh the page.

This was done on Chrome. Same exact behavior is also seen on Safari.

The link gives an error for me.

Sorry, try now. Venmo takes a few mins to prep the video.

Direct link - https://vimeo.com/423423858

1 Like

Yeah that is weird. I just did some testing and was able to replicate some very odd behavior. You can try the "Remove This State" button. It won't really 'remove the state' it is more of 'reset to default' It will remove the color plate, but after you close and reopen the template screen it returns. I had limit success with it.

@bobbyD I'm not sure who as best to tag for dashboard related issues, but the shade template has some color saving issue. Check out the video above and it should be easy to replicate. I have not tested anything but shades.

I noticed the same thing today for my dimmer template; it had custom colors for both On and Off states.
I tried this and it surprisingly worked to remove the custom colors.

  1. Start fresh; refresh dashboard page you are on and go straight to Settings Gear -> Templates tab
  2. Click Dimmer(in my case) -> Click On State -> Click Remove This State button
  3. Click Off State -> Click Remove This State button
  4. Click Save one or three times just in case :facepalm:
  5. Refresh page

I went back into Settings -> Templates -> Dimmer and when I checked the On state then the custom color was finally gone, no 'Remove' red text was to be seen. Same thing for Off state :phew:

(Not sure how to edit post so tacking this on)

What might be happening is that when you click the Remove This State button and then immediately click on either On of Off state to see if the remove button did its job, the existing custom colors get placed back into effect. And only after you remove the states and refresh the page before checking then it actually applies the removal of the custom colors.

So in this case checking your work immediately after trying to remove/set back to defaults just causes it to reapply the custom colors that are currently active.

1 Like

(Not sure how to edit post so tacking this on)

Welcome to the community. There is a 'Pencil' icon to edit your posts.

I went back into Settings -> Templates -> Dimmer and when I checked the On state then the custom color was finally gone, no 'Remove' red text was to be seen. Same thing for Off state :phew:

I have had success using the same method albeit sporadically. It doesn't work for me all the time though.

Hmm it doesn't seem to appear for me (I'm also not able to add an image to this reply so show what I mean). Maybe I need to make more posts or some other form of seniority before I'm able to edit. Either way, thank you for the welcome.

This issue is still very much an issue. I've been fighting with this for well over a year and finally found this post (not sure how I didn't find it before).

poland123's description of the issue and the suggestions to remedy it seemed to finally make some sense of the odd behavior that has been happening.

Putting this there in hopes that this might some day get fixed and also to let others know it is still happening.

1 Like

I've been fighting it as well. The templates have real problems. The reason you didn't find it before is that the search function in the forum doesn't work very well and things get missed. I stopped using it and just google for habitat + <whatever I'm looking for>.

That usually gets me better results.

To over come the shortcomings in the template implementation, I edit the json layout directly. I still use the color interface to get the numbers I need, then go edit the json to fill in all the states.