Dashboard Customizing

Hey Guys,
2 Question from a new user :slight_smile:

  1. I've added a openweathermap driver and i get the stats from the site:

Current States

  • temperature : 23
  • weather : clear sky
  • weatherIcons : 01n
  • windDirection : 70
  • windSpeed : 2.06 and so on...

when i enter the dashboard and trying to add a tile for weather information i don't have weather in devices, and if i pick weather in template i get a tile without information in it... what am i missing?
do i need to add anything else besides a weather driver? how do i add weather tile? :confused:

  1. I have a z-wave device with dual switches, in devices i can see 2 child switch components but if i wanna add a tile for it in the dashboard i can only see the parent device, i wanna control each switch separately in the dashboard, how? :slight_smile:

Thanks,
Lior

@thebearmay is likely to provide a more accurate answer than I can , but you are likely selecting the wrong device / attribute.... But I will let @thebearmay finish...

1 Like
  1. Did you create a virtual device using the driver Devices|Add Device|Virtual|Deivce Type As a user defined driver it will be near the bottom of the list.

  2. What device and driver is this?

1 Like

Hey,
Thanks for the quick reply.

  1. i did create a virtual device, put the api key and my info, i do get "current stats" in the device itself... type of device is "openweathermap"
    just have no idea how to put the data it gets into a tile at the dashboard :confused: (or i added the wrong driver but i don't see how) - type should be "openweathemap" in the device right? :slight_smile:

  2. Used the build in "Generic Z-Wave Plus MultiSwitch" and both child devices are "Generic Component Switch" - can't see tiles for each child device, only the parent (and it dual switch controlling 2 lights)

  1. Generally the weather devices have a number of attributes defined that contain HTML for the dashboard. You’ll use the Attribute Tile Template to display those.
  2. Going to defer on this as I don’t have one to look at, but someone should jump in shortly.

Did you also go to the Apps tab, select this particular Dashboard app, and include the device in the list of allowed devices?

Did you add the parent, the child, or both to the Dashboard app as shown above? You only need to add the two child devices, the parent in your situation is irrelevant. From there, you should be able to pick the child device in the Dashboard left column, and switch in the middle column.

That was it, THANK YOUUUUUUUUU!
Didn't mark them on the allowed devices for the dashboard!
Thanks everyone :heart_eyes:

Download the Hubitat app