Dashboard and getting into Dashboard SLOW

Im hoping this is due to influx of new users this Christmas morning, but Im sitting here for MINUTES while this thing loads, I thought I was doing something wrong because it took so long to get into the dashboard.

Surely this isnt normal? Migrating from Wink, so it can't be as bad as that, right? RIGHT?!?

Have you selected only the devices that you want to show on the dashboard or all of the devices you have installed.
Only selecting the ones you want to show on a specific dashboard does speed things up.

Im literally trying to get into it for the first time and it took up to 3-4 minutes to load I believe.

Ill look into that.

I just loaded my home dashboard from a remote location. It was pretty quick.

Anytime I go to a new screen, it takes forever.

Starting to get seriously frustrated.

I have a main dashboard with my commonly used devices. The main dashboard has links to room focused dashboards with all devices in that particular room. I'm having no issue going to the room focused dashboards from the main.

Sorry, I have no suggestion on how to speed up the dashboard. Hopefully someone can help you.

What brand of network router or switch is your HE connected to?

1 Like

I have a ZyXEL VMG4381-B10A

Using the Chrome browser?

Currently using Safari, but I tried Chrome earlier and didn't seem to notice a difference.

Your mileage may vary with anything except chrome . . .

Yeah, I just pulled Chrome back up and seems very responsive all of a sudden.

However I did just try to load dashboards from looking at Logs and seeing a long load time again.

Did you see the article about limiting the devices you have enabled for the dashboard? Apparently, if you enable a ton of devices, it may slow the dashboard way down even if you are not using those devices on your dashboard. Some people just enable them all, figuring they might want to use those devices but then their dashboard performance really stinks. I'll look for the link but I think I have given you the summary of it.

I haven't even gotten anything linked up yet. I just got it turned on today and have been struggling to get my switches linked up.

Only thing "connected" is my Echo at the moment.

I see I'm on firmware version, would updating this hopefully help me out?

I have it checking for an update, but again, it seems to be "stuck" in this mode.

Edit: So I got the update confirmed and have started the download. I tried to reload the page while it was "stuck" and ended up having to go back a page and back into checking for update and it was there.

Just another update, for those who may come across this.

I got everything operating smoothly, no slow loading. I failed to do the most basic thing, restart the damn thing. Once I did that its flying, on load times.

Ill try moving the hub closer this weekend to my switches to see if that helps that issue.

I know this wasn't your issue but as bobbles suggests, you don't want to just select "All Devices" for dashboards when you do go to set them up. I had done this initially and they were slow loading. Once I went back and only selected the few devices I needed on each dashboard, they were much faster loading.