Custom App Preference Titles Gone

Have several custom apps. Went to change one of the selected items and noticed the preference titles are missing. Checked several other apps and same thing. What happened? Here is what i am seeing.

Anybody got any ideas on this? It is a major problem for me. All my apps are doing it and it just started with maybe the last, or the one before that, hub update.

I've tried 3 different browsers in case that was the issue. No change. 2 different computers also no change.

Can you edit the picture to add in what you think is missing? I can't read the code, so I am not sure what it is supposed to be displaying here.

My community based apps appear to all be normal, but maybe I don't know what I am missing.

In the app code where it says section("something here") that is the title for each section of preferences. That title should show up above each section of inputs in the app configure. And they always have before.

Well here's something interesting. I can't add any apps. Both built in and user apps show up but when I click on one of them to add it, it does nothing.

Just checked on my hubs, and every one of them displays the section title correctly, 2 are on the other one is on .116

This must be something local on your side, did you try rebooting the hub?

1 Like

Tried rebooting, no luck. Did a soft reset and restore, no luck. I can now add apps, but the titles still don't show up on any of them.

EDIT: And now it won't let me add any apps again.

An app I tried to install to test, never installed but is spamming the logs. So something really weird going on here. Who should I tag at HE to weigh in on this?

Same here.

Did you try taking a backup and soft reset then restore?

As mentioned above, yes I did.

Did another reboot and now I can add apps again, both built in and user. (Not going to try the one that spammed the logs tho. :stuck_out_tongue_closed_eyes:)

But still no titles. Going to hold off doing anything else until maybe you guys can come up with something else to try.

By the way, It's a C5 on .117.

I created a simple app to test. It has the same problem. Here is the code and a screen shot of the app. There must be some setting somewhere that isn't allowing those titles to show up. Maybe a color setting??? If the title is white then it wouldn't show up on a white background. But I don't know anyway to change that.

 *  Test App
 *  Copyright 2022 Jim White
 *  Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except
 *  in compliance with the License. You may obtain a copy of the License at:
 *  Unless required by applicable law or agreed to in writing, software distributed under the License is distributed
 *  on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License
 *  for the specific language governing permissions and limitations under the License.
    name: "Test App",
    namespace: "jwwhite001",
    author: "Jim White",
    description: "App Outline For Testing",
    category: "My Apps",
    iconUrl: "",
    iconX2Url: "",
    iconX3Url: "")

preferences {
	section("Inputs Required") {
        input "switchInput", "capability.switch", required: true, multiple: true, title: "Switch Input"

def installed() {
	log.debug "Installed with settings: ${settings}"


I'll tag @bobbyD because I'm not sure who maintains that part of the code.

1 Like

Playing around with stuff, if I add a page reference enclosing the preferences it works. Wish someone could tell me why I need that when I didn't use to need it.

Here is what I added:
page(name: "page1", title: "Test Page", install: true, uninstall: true) {
Here is the new app look.

Hate to keep belaboring this, but sure would like to find out what is going wrong. I realize I found a work around, but don't know why that would be needed.

Anybody know what I can do to try and figure this out? Or who I should contact?

Possibly @gopher.ny, as he handles most of the base platform development.

1 Like

I find it odd that I haven't seen any other reports of this "bug". To me, that indicates something on your end, or some odd circumstances that others have not duplicated yet.

I agree. Since all my apps are doing the same thing it should be solvable. I canโ€™t think of any changes I did before this started. Other than adding the HomeKit integration. Donโ€™t see how that could have any affect. I just donโ€™t know where to look.

I just thought of something. Go to Settings tab, and see if "Enable Screen Reader......" at the top of the page is turned on.