Custom Actions in Rule Machine 4.0 went missing?

Hi Everyone,

I was trying to re-create some Button Controller actions for my Lutron Pico remotes in Rule Machine 4.0. For Buttons 2 and 4 I would like to be able to dim the lights up and down respectively. I was able to make Custom actions for this with the following actions:

DIM UP Button Actions (Button 2 Held)

DIM UP Button Action (Button 2 Released)

DIM DOWN Button Action (Button 4 Held)

DIM DOWN Button Action (Button 4 Released)

Everything was working fine but I noticed that if I held the button too long one of the lights in my group would flash. I was testing out why this was happening when the light suddenly reset. I had to remove the device and re-discover it and add it back to my groups. At this point my buttons using the logic above showed Broken Action. I removed the broken action from the button and tried to re add it but now the options for startLevelChange and stopLevelChange are missing from the custom actions list. I have tried to reset the hub, clone the rule and re add the custom action, and create a new rule. No matter what I do those options are missing from the custom actions list. Any help would be appreciated, thanks!!

Sorry I would have added this originally but I just created my account and I didn't have the rights to post pictures yet!

Groups don't support startLevelChange and stopLevelChange, only individual bulbs do. You also don't need a custom command for this, though I guess that works just as well--you can use the "Start Raising/Lowering Dimmers" and "Stop Raising/Lowering Dimmers" actions that are Rule Machine's friendly names for running these commands (still doesn't help if the device/group you've selected doesn't support it, which I guess choosing a custom command would show you).

So, my guess is that you had selected a bulb and not a group before. Also, you don't need to delete a Zigbee device of you just want to re-pair it unless you want to remove it from all automations. If you just reset the device and re-pair it, Hubitat will recognize it and reassociate it with your existing device (again, only for Zigbee). That being said, I've still noticed the need to go into Groups and Scenes and click Done on any app that uses them, even though I'm not sure that's expected behavior...

@bertabcd1234 Thank you for responding! You a are right, the commands I was trying only work on individual bulbs instead of groups. I did try the "Start Raising/Lowering Dimmers" and "Stop Raising/Lowering Dimmers" actions, these also don't seem to work on groups but they work on individual lights just fine. Feels good to finally have the pico remotes working at their full potential!

Great, I figured you couldn't re-discover devices, this makes it a lot easier.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.