Conditional Access for Paused Rules not functioning

I've got a couple of automation rules that close my garage doors after 20 minutes; I also have some automation on a button controller that pauses those rules.

I'm working on a new button trigger that does some automation and then checks to determine if (one or more) of my Auto Close Rules are paused to tailor the next set of actions. However every time I try to add the condition I can't seem to update the drop down on the "rule paused?" section to get to a "Done with this Condition" button.

When selected, the drop down flashes a list (maybe three) items by and won't let me select them and folds back up w/ the default "Click to set" drop down.

Some of my configuration specific details:
Running a Rev C-7 Hub on Platform Version 2.3.0.113, I've tried two separate browsers on my computer as well as my mobile browser.

The (production) rules are RM version 5.0. The names are also fairly long, the longest one is 55 characters and contains both open and closed parentheses as well as hyphen's. I cloned one of the rules, to a 9 character name and only a hyphen as a special character in the list as well still no dice.

I've also created a new (empty) RM 5.1 rule and have the same experience.

Additionally I've tried to tab around to get to the drop down and get it to select w/ keyboard input but it always seems to revert back to the gear for the rule.

What is odd is that the select points for the drop down, the 'not this condition' and the 'cancel this condition' button all seem to float they don't always trigger when I click/tap them and have to fight w/ finding an active option to even cancel the condition.

I do also have 3 other conditions on this rule (open/close detection conditions)

How to re-create:

  1. Open Rule
  2. Select actions
  3. Select Manage/Create Conditions
  4. Select "Rule Paused" from the capability for the new condition drop down.
  5. Select the Rule to validate

At this point I'm no longer able to edit the condition for the rule and have had to resort w/ eventually trying to cancel the Condition.

Edit: Added Detail on additional conditions w/in rule.

1 Like

I'm seeing what I think is the same thing: the "Rule paused?" dropdown briefly appears, but I'm not able to select either "paused" or "running" from it becsuse it disappears too fast. This is in iOS Safari with Rule 5.1 in 2.3.0, but it sounds like you've tried various combinations.

Tagging @bravenel In case this is an RM issue, otherwise I'm guessing he'll refer it to their UI person (people?).

Sounds very similar, I have tried from Safari on my mobile as well as two other chromium based browsers from my Windows PC.

Yeah, there's a refresh loop happening with this. Not good. I'll track it down.

2 Likes

This bug has been found and corrected for next release.

2 Likes

Wow! Thanks!

Question: when you say "next release" is that the next minor release or bug fix release? I've updated this morning (2.3.0.120) and still having the same situation w/ conditional access for paused rules. Based on experience, I'm guessing a 2.3.1+ type release but wanted to know so I didn't just randomly re-try rule updates w/ every bug fix update.

Well that's odd. I could have sworn that got fixed, but yeah it's still doing it. I'll look into it again.

1 Like

Good question at this point. We were basically done with 2.3.0. I did find this bug and fix it, again. The fix got lost in a dev version of Rule 5.1, and didn't get merged before. Not sure at the moment when this will be released.

1 Like

Download the Hubitat app