Completely unresponsive hub - help!

I woke up this morning to a fully unresponsive Hub. No automations, nothing. The light on the front is green. My router (Google WiFi) shows that the device is connected and assigned its usual reserved IP of Going to that address simply times out the browser. I disconnected power, waited 5 minutes, and plugged it back in. Same thing. Replaced the ethernet cord and did another power cycle as before. Same thing. I'm terrified because I didn't realize that the backup that Hubitat does have a weak point in that it's on the device (there should be a way to set up automatic off device backups, but I digress). What do I need to do???? I have 125+ devices, 50 some automations, etc., so the idea of starting over is quite overwhelming! HELP ME!!!!

I think the first step is see if you can get to the Diagnostic Tool:

You will need to copy the MAC off of the back of the physical Hub for use in the tool.

The tool is documented at: Hubitat Diagnostic Tool - Hubitat Documentation

1 Like

YES! That worked - I'm in! Given the circumstance I described, what would be the least destructive thing to try first?

I would try a shutDown, unplug the hub, then plug back in. It is the normal way to restart.

1 Like

Shutdown hub (from the menu at port 8081)
Cut power
Wait a minute and turn power back on

Exactly what @djgutheinz said.

I did a reboot first (figured I'd document this in case it happens to anyone else!), It did a reboot, brought me to the main menu (progress!), but trying to go to settings (backup!) resulted in no response from the device. Going to do what dj said now!

Uh oh.

The Shutdown request gave me "Error: Request failed with status code 401"

and now the reboot results in the same error. Hmmmmm

That's an authentication error. Please repeat it using an anonymous/private browser window.

1 Like

Log out. Log back in using Mac from bottom of h7b

Did shut down. Pulled plug after light red, Reapplied power after 5 minutes. Boot back into diagnostic mode (oddly enough, WHILE the device was booting, it did ONE automation when I pushed one of my smart buttons). Went back to main menu. Clicked "setting" and back to where I started - unresponsive main menu. At least I know it's not totally dead! What should I do now (I have to leave in about 10 minutes, so when I disappear, it doesn't mean I've solved the problem - I'll report here when things are restored!). THANK YOU all for your help. Realizing how much we actually rely on this thing now!

Also had to open a NEW private browser window to try something else. I booted in safe mode and the device is now responsive... I'm downloading a couple of backups, and restoring a backup from 2 days ago when things were working (I did add a new automation last night?)

I'll report back tonight - gotta go! THANK YOU!!!!!

1 Like

I seem to be back up and running now! THANK YOU!!!!@

1 Like

We sure do. I keep 30 days worth of offline backups for each of my Hubitat hubs.

Restore this after doing a Soft Reset. Never do a Full Reset without consulting @bobbyD.