Color device not being set correctly


#41

this is more like what I have been trying to do but it wouldn't work.


#42

No, this doesn't work. So that's a but that should be fixed. It should only allow a single delay per mode irrespective of the type of device. If you select delay per mode for Day mode under Dimmers, and then have Switch per mode, the delay you entered before will show up there. It should work that way throughout. There is only one delay per mode.

Correct. You only select modes that you want the app to work for. It will ignore others. What I was referring to about a not defined delay for a mode, is suppose you have Night mode, but don't enter a value for the delay for it, In that case, the delay will be 1 by default.


#43

yes that's make sense, but is not what i found. I have notice a new thing since i found it though so I will set it up fully again and retest it all as you make have fixed with ought knowing? I'm assuming adjust levels when mode changes is new? Will this work for both temperature/ colours as well as the dimmer level? If it does that's one less rule i need :slight_smile:

Edit:

also what's the idea behind this?


It creates a device, should i then add this device to GH instead of the atual light direct so that the app can track it?


#44

You lost me with that one. The default delay-per-mode is 1 minute.

Adjust level on mode change will run the turn-on function upon the mode change. So that will adjust all of the lights, etc. based on the new mode.


#45

the delay is the default 1 min but i had filled in its time, but was still getting the default 1 min.


#46

If you mean the Large Bedroom light, if you include that device in GH then you can turn on, off, or adjust dimmer level from GH for all of the lights selected in ML. Adjusting dimmer level only works for dimmers, not other device types (CT, color).


#47

so it essentially creates a new "group" of lights that controlled in that particular app?

So for a CT, colour device I would still have that in GH as well so I could adjust its colours individually but if I wanted to control the whole room under the ML app I could use that device instead but only on off up and down :slight_smile: I like it :wink:


#48

Effectively, yes. We don't have color lights, just dimmers. We use this for our kitchen, along with override. Telling Alexa or GH to adjust the lights will engage override. So for example, the dim level in the evening is sort of low for cooking, but I can tell Alexa to set it to a higher number -- hands free since they're engaged. It will stay there while I cook.


#49

issues are the same. mode is in evening currently so as below should have sent 4000k with delay of 10 mins and it delayed 1 min


app logs

[app:742](http://192.168.1.81/logs#app742)2019-01-09 06:36:20.695 pm [info](http://192.168.1.81/installedapp/configure/742)Override ended by (SmB) Pendent

[app:742](http://192.168.1.81/logs#app742)2019-01-09 06:36:19.122 pm [info](http://192.168.1.81/installedapp/configure/742)Turning off

[app:742](http://192.168.1.81/logs#app742)2019-01-09 06:36:00.411 pm [info](http://192.168.1.81/installedapp/configure/742)Enabled at this time

[app:742](http://192.168.1.81/logs#app742)2019-01-09 06:35:19.053 pm [info](http://192.168.1.81/installedapp/configure/742)Delaying off for 1 minute

[app:742](http://192.168.1.81/logs#app742)2019-01-09 06:35:19.004 pm [info](http://192.168.1.81/installedapp/configure/742)Motion inactive (SmB) Motion

[app:742](http://192.168.1.81/logs#app742)2019-01-09 06:32:45.491 pm [info](http://192.168.1.81/installedapp/configure/742)Not turning on color: wrong color mode Evening

[app:742](http://192.168.1.81/logs#app742)2019-01-09 06:32:45.460 pm [info](http://192.168.1.81/installedapp/configure/742)Setting colorTemp [(SmB) Pendent] to 4000 at level 50

[app:742](http://192.168.1.81/logs#app742)2019-01-09 06:32:45.457 pm [info](http://192.168.1.81/installedapp/configure/742)Not turning on dimmer: wrong dimmer mode Evening

[app:742](http://192.168.1.81/logs#app742)2019-01-09 06:32:45.447 pm [info](http://192.168.1.81/installedapp/configure/742)Motion active (SmB) Motion

device logs

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:36:20.634 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent was turned off

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:36:20.633 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent was turned off

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:33:53.124 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent colorMode is CT

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:33:53.122 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent color is Polar

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:33:52.956 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent colorTemperature is 6535°K

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:33:52.758 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent saturation is 100%

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:33:52.524 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent hue is 100%

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:33:52.469 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent is 50%

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:33:52.454 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent is on

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:32:46.481 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent colorMode is CT

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:32:46.466 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent color is Polar

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:32:46.404 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent colorTemperature is 6535°K

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:32:46.169 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent is 50%

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:32:46.060 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent is on

[dev:513](http://192.168.1.81/logs#dev513)2019-01-09 06:32:45.901 pm [info](http://192.168.1.81/device/edit/513)(SmB) Pendent was turned on

events


#50

Delays set for CT or color don't work. They will always revert to 1 minute. In next release, the same delay per mode will be in effect for all devices. If you set them for a dimmer, switch, scene or button push, in that instance, it should work for you. All devices follow the delays set for one of those. There will not be separate delays for different types of devices, nor are there now. That was a mistake, and it doesn't work.


#51

Brilliant knew it wasn't just me :thinking:

would never have expected it to, hence why I found it odd there were multiple options.

what about

Is that connected to the delay?


#52

What about it? It sent that according to the log of events you show. And no, it's not connected to delays.


#53

I think you this was where we go to last time and @mike.maxwell needs to look at the driver because its not processing the commands


#54

@bravenel Most things have been fixed on the latest update, including it seems to have fixed the max 3 command issue, still need to do some more testing though. I have one room that the chandelier doesn't turn on night sleep mode, this must be because there are other lights in the mix. The other rooms with only one light, with similar set ups work

Also notice something else at the bottom it says disable off during evening and night but if I click into it and done it then shows this. I did this last night, so it's got some phantom information.


#55

That's probably just a UI bug. I'll track it down. All of that blue text is generated for UI purposes only, and bugs can happen in that code. It's just an extra CRLF stuck in there.


#56

@bravenel it seems to have improved as in the colour almost always changes in night mode but it still doesn't work for the colour temperature. It turns on but doesn't change to the correct value, but if motion become inactive and then active again before the time out it will then correct the light to the right colour temperature. Everything is correct in the logs it just can't deal with the messages but this is for a standard one lamp (the set up above)

I also tested a grouped set of lights and the same happens apart from the end bit, because in the group dimmer device it says that the kelvin HAS changed but the main devices show they haven't. so there may be something in the group's that is also a problem. I wonder because the its says the state is correct it doesn't send the kelvin when the motion become inactive and active again before the time out? As this is the difference between the two setups were the 1st sorts itself out the group setup wont it will stay on the wrong level indefinitely it seems.

Group set up



#57

also this still is funky, although it works, it doesn't let you change the delay per mode on any of the option's. By this i mean if you have selected delay per mode and colour per mode and ie temperature per mode and on the 1st option you put in a time, when you select the next option like colour per mode and select the same mode it will already populate it as you would expect. But if you change your mine and try to adjust it will keep reverting back until you change the "one it wants to to change it on" does that make sense? So the auto populate seems to work one way but not the other


#58

This is still a issue and seems to be worse again, not sure if there is anything in it or its just a coincidence that it seems worse. But it still doesn't send all the commands it should.

What I've tried as a work around is splitting it over two apps and it works but not for the RGB because there is no colour per mode yet.


The idea being this does the ON.

Then this does the temperature (future colour and level)


#59

Once again, all I can suggest is to look closely at the logs and events. Logs for both the app and the device, both with logging enabled. Also at the app events and device events. This is the starting point to figure out what is wrong.


#60

We have done this everything in the apps are fine and are being sent what seems like correctly. So it leads to what seems to be the driver but as it's a stock one, I'm not sure what I can do?