Cloud End point issue


I was on v., and upgraded to v. and my issue is not fixed, so I thought I'd ask for help!

I created a cloud end point as a trigger in RM. In the past I would be able to click on it, edit it or delete it. Now when I click on the trigger to edit it, nothing's there. No select trigger, edit trigger or delete trigger button.

When I click on the trigger this is what I get:

If I go into settings, I see the cloud end point listed:

I need to modify this trigger. I have the same issue with another Rule triggered by a different cloud end point,

I tried copying the rule to see if this would solve the issue, but i doesn't.

Could anybody help? Is it a known bug? I couldn't find any post on this.

Thank you!

Just tried it on cloud end point rules on a C8 and a C5 both worked as expected.

Thank you. They used to work as well for me, but not anymore. I am on a C7.
What could be the issue?

Likely a "corrupted" internal rule state, often the result of using your browser's "Back" button (or otherwise navigating away from the page) while in the middle of doing something, in this case, possibly adding or editing another trigger; or removing a device the rule was using without removing it from the rule first. I'm not able to reproduce this problem with cloud triggers I have set up, so I suspect it is not a general problem. If you don't think it was something like this and can figure out how you got into this state, there could be a fixable problem somewhere, and that information might help; otherwise, you'll probably need to figure out something else.

As for what that is: "copying" the rule in the sense of cloning is unlikely to help; you'll copy the exact same internal data, and the problem will come with it. Re-creating the entire rule would be one solution.

That is likely your best course of action at this point. Keep in mind that you can copy and paste actions between rules, which might make this easier. Probably the only other thing would be if the Rule Machine author wants to look at your internal app data to see if he can figure anything out that would help; unlikely, but it's happened in the past, and staff are active on the forums, so he might see this. :slight_smile:

1 Like

Simple, but have you just tried clicking done on the app page?

1 Like

Yes I did :slight_smile:

Thank you @bertabcd1234. I'm certainly guilty of using the "back" button freely...

I will try recreating the rule and see if it works - by copying the actions of the current rule (good point: I was trying to avoid recreating the whole thing!).

@bertabcd1234 It worked, thank you!! Love that I learnt how to copy actions from one rule to another!

1 Like