Cloud Backup on C7 with Hub Protect not working

I originally did a cloud backup when I first started using the C7 after purchase of the Hub protect & Remote Admin. I had not done anymore with that as I usually backup locally and share that to a Google Drive. I saw the "scheduler for the Cloud backup'' and thought I might set that up but decided to do a "manual cloud backup" . It showed "processing" but a backup in CLOUD never appeared. I also tried the scheduler and it did not make one either. I've tried it with IE and Chrome, also using my Samsung phone and all do the same. I even tried it again with this latest update as I thought a fix might be in there. I also did a complete shutdown and reboot and nothing changed. Everything else is working super and there is no "rush" on solving this, just like to get it working in case I need it, or figure out what I'm doing wrong.
I've submitted a ticket to Support, with the above paragraph, and have not heard back yet, and know they are busy so that's not a problem, I just thought I'd post here to see if anyone else is having this problem, or if someone had it and fixed it, how did you fix it. Thanks in advance for ny suggestions.

Never mind, after a power outage it started working. Apparently it was running cloud backups but they were not displaying.