Chromecast integration (Beta) issue - no TTS until play

I have been having an issue with the Chromecast integration.


Speaker Group is selected as the TTS output device for send message action
Speaker Group =

  • Living Room TV (Chromecast Ultra)
  • Living Room Speaker (Google Mini)
  • Master Bedroom Speaker (Google Mini)

If all devices are turned on, the TTS message is spoken and heard on all devices within the Speaker Group.

When the Living Room TV is turned off and action is run, an error is issued for that device.

Rerun action and Living Room speaker stops speaking the TTS message. Bedroom Speaker continues to work.

No matter what I do, the Living Room speaker continues to fail on ALL other rules using it as a TTS output device. I tried resetting the speaker. I tried making sure the speaker was the only output device. I wrote new rules. Nothing worked.

I tried testing the TTS function from the device configuration page for the Living Room speaker with no joy.

I pressed the PLAY button (out of curiosity) on the device configuration page for Living Room speaker and all messages from all previously triggered actions from all rules are spoken in the order the action was run as if they were queued up. Basically, it pukes :face_vomiting: up all TTS messages.

What is causing this?

Queuing of messages was a community request so it was added to the integration.

How about sending a stop() custom action to the Living Room TV? Does that stop the errors from occurring? If that works, then maybe you can figure a way in your setup to send stop to the TV when it is turned off?