Child device (Zen30 relay) not showing up in Google home

Title says it all. How do I get the child device on the Zen30 to appear in Google home so I can control it there. Using it to control the fan on a ceiling fan unit and the light shows up in GH just fine.

Did you install the Google Home App and share the device to it?

Yes, like I said I have the parent device, the light, added and working just fine. Just can't figure out how to the the relay to show in there as well.

No one? I've tried changing the device type on the child device but it won't let me. Excluded and re-paired two times. I'm at a loss....

You don't see the name in your Google Home list? Remember if you add a Device Label, that's how it shows in the list.

I have all of my devices showing in the lists for Alexa and Google Home, and I just check them off to send them to the respective assistant

Nope, not showing up at all. I've tried changing the device label but I don't even have that option. Just the parent device is showing in Google.

I'm sure there is something simple I'm missing but being new and not too familiar with this stuff I'm not sure what it could be.