Chamberlain MyQ Garage Door Support [OUT OF DATE]

Thanks, that's the one I've tried but it's only showing one of my doors.

But logs indicate that 2 were found. I'll start digging through the code:

and both are set up in the MyQ app under the same username? Have you tried installing another instance of the app?

The code was wrong. I fixed it and submitted pull requests; @thomas.c.howard accepted the changes in his version.


Your fork seems to install without a hitch, any chance you would consider adding the ability to disable the debug logging?

This was great! Finally able to get my garage doors integrated into the Hubitat ecosystem...thank you!

This is fantastic. Any possibility of adding a 5th door?

It should just work.

I can select 5 doors on the Device selection page, but can only select the optional sensors and push buttons for 4 doors.

I’ll look at it this weekend. I don’t have a computer for a few days.

1 Like

I changed the code so it should support up to 6 doors. Since I only have 2, I can't test. Let me know if it works for you.

1 Like

Just tried it and it worked then Chamberlain locked my account >.> . They are really pushing for their paid service I guess.

Update: installed a different variant & reset password and it seems to work now.

I'm moving from ST to HE
I used to just use the github repo integration without the copy/paste
I forgot what needs to be copied/pasted in the app section and driver section

Any help is appreciated

Under Apps you need to copy/paste the App My Q Lite.

(I'm assuming here, that you have a garage door sensor)

and you also need the device handler for MYQ Garage door.

Also, you need the Momentary Button Tile Driver (from SmartThings)

@halfrican.ak did you ever get rid of this error? Its showing up for me too.

This version has bugs which I've asked the author (@thomas.c.howard) to incorporate into their version. Perhaps he can review and merge them so everyone is working from the same branch.

1 Like

Reviewed and merged. Thanks for the help!


Thanks @thomas.c.howard do you have any ideas about the error i posted a couple posts up?

so myQApp.groovy is the app code, rest of files go to drivers code?