Chamberlain MyQ Garage Door Support [OUT OF DATE]

Anyone else receiving errors now with MyQ?

errorgroovyx.net.http.HttpResponseException: Bad Request on line 922 (sendCommand)

Also in homebridge receiving:

Error getting MyQ devices: Error processing request (217)

I'm guessing MyQ changed something?

Seems to be working for me. What were you doing when this happened?

I first noticed via Homebridge that I was receiving a ' No Response ' error. I then checked homebridge logs and noticed:

0|homebrid | [3/25/2020, 10:00:34 AM] [MyQ2] Error getting MyQ devices: Error processing request (217)
0|homebrid | [3/25/2020, 10:00:43 AM] [MyQ2] Error polling MyQ servers: FetchError: request to https://myqexternal.myqdevice.com/api/v4/UserDeviceDetails/Get failed, reason: read ECONNRESET

Then tried to control the garage via Hubitat and noticed this error:

errorgroovyx.net.http.HttpResponseException: Bad Request on line 922 (sendCommand)

Haven't touched anything in months prior to this.

Is there any documentation on how to create/modify dashboard templates ?
I have tried the Garage Door (control) and a variety of separate devices like switch, bulb, door status etc
I have installed the MyQ Lite with Sensor and added an independant ZW Tilt sensor as recommended and this status is read by the app
What is missing in the Garage Door Opener Status (Opening/Closing)
After I press the Garage Door (control button) The MyQ App reports the opener status as opening or closing before motion starts
The tilt sensor at a later time shows Open or closed inside the MyQ app and on the Dashboard.
I would like to see both Open/Close state from Tilt Sensor and Opening/Closing activation state of Opener

With a sensor, the Garage (control) dashboard tile should be correct. It should show current state.

Which app and driver did you use? There have been revisions to this over time, the latest is in this thread: Updated MyQ Lite Application

You can also add a separate tilt sensor tile, mine works as both "Contact" "Multi Sensor" and "Door Status". It will depend upon what tilt sensor you have to which tile works best. I use Multi Sensor so I can get temperature from my Smartthings multi sensor.

Just to note to all future readers:

Much of the above information is out of date. The apps and drivers above likely no longer work as they should.

You should be using the below app and driver.

Any issues you encounter with that app or driver should also be directed to the link below.

4 Likes

What I have found is that if I open or close the garage door from the Driver or Dashboard, the Opening/Closing status is correctly reported. Otherwise it is not.

Yes I was just observing that in the Garage Door (control) tile but I seem to be having problem with the new Ecolink Z wave Tilt sensor so the MyQ app is not working properly. Will see what I can do about that sensor or change to a different type of sensor. Maybe the metal door is affecting it. When I remove it and tip it up and down it start working again.
With the Switch template the door can still go up and down even when the sensor doe not operate, but with the Garage Door template can not operate the door due to the incorrect feedback. Still interested in how to develop templates if anyone knows ?

I have been using the Samsung Contact Sensor and have not have any problems with it. I would buy it again.

As an added bonus, it provides the temperature, so you can have an idea of the garage’s temperature. (It does report colder temperatures during cold Canadian winter days though...)

As for dashboard templates, I don’t think new ones can be added... but it is possible to use the “Attribute” template to setup anything that is not in the list.

There is a correct mounting for that sensor. It has an arrow stamped on the sensor that has to point up. It also says in the manual it should flash the LED when tipped (and I assume) also when the door is opened and closed.

Sometimes it is better to mount the sensor higher on the door so it reacts better.

And metal shouldn't really affect it. It is made to go on a garage door so that would be really silly if you couldn't mount it on a metal door.

And far as I know there are no user dash templates. You can request to have a different one, but adding a new one that (essentially) copies the function of an existing one is probably not very high on the Hubitat team's priority list.

1 Like

I can confirm that it works on a metal door as this is what I have. I’m not sure if I have it mounted in the right direction or not, but never had any issues... (Apologies for the picture being sideways... For some reason, photos imported from the iPhone here do that sometimes...)
image

I now use the Package Manager app to ensure I have the right version of this app (and a bunch of others...). It also will install updates if any are available and if I want it to. Really nice!

2 Likes

Definitely mounted right way up more testing found that Z wave signal not working at all. Checked the Aeotec Z Wave extender may have been an issue, The outlet in the garage plugged into trips occasionally when the family run the washer and wife has her car charging. Solution move the ZW extender to another nearby outlet that is not affected by this overload condition. Tilt sensor is working now. But there is some strange stuff going on with the Dashboard tile open/close state on the Phone, Computer is OK but phone dashboard tile states not updating ?

Package installer sounds nice after messing with the Nest app and drivers for a week but ended up having to delete as could not get Authenticated, will now have to wait on the google API as I understand it.

iPhone app must have crashed. After I killed the app and then restarted the Dashboard app started working again. Strange some stuff was working like he switch to start the door opener but tile status was not updating. All good now.

1 Like

You need to make sure to follow all the prompts or it will not create the additional devices like the sensor and light switch, if you have one.

Are you using the MyQ sensor. This App works much better when you have the matching sensor.

You realize you are replying to a post well over a year old?

2 Likes

It is working for me. I even created the actuators for the dashboard so I can use the closer one only for the phones dashboard.

You have to use the On command to open and off to close. Odd but it works.

This is an old thread. The information here is no longer relevant. It probably should have been locked.

Everyone please refer to the newer thread linked below for the latest information.

5 Likes

Download the Hubitat app