Centralite keypad problem with mesh

Hello
I have two centralite keypads that I use to arm HSM they work great.
Because of wireless issues in a large brick building I decide to move one of the keypads onto a second habitat using mesh.

Lets call the keypads main and mesh

So the main keypad works just fine and the mesh keypad follows the main keypad status showing home/night/away modes beeping etc.

But the mesh keypad doesn't change the status of HSM or the other keypad just its own local keypad status so I cannot use the mesh keypad for anything other than indicating the status of the main keypad.

Anybody have any ideas as its making my head hurt.

@doug5 - Did you ever get this to work? I've run in to the same issue with my Iris v3 keypad. If HSM is installed on the same hub as the keypad is paired to, it works great. I can both arm and disarm HSM from the keypad and if HSM is armed or disarmed from the GUI, the keypad will reflect the changes.

However, if HSM is installed on a different hub from the one that the keypad is paired to and the keypad is "shared" to the HSM hub using Hub Mesh, it doesn't work all that great. I can neither arm nor disarm HSM using the keypad, but if HSM is armed or disarmed using the GUI, the keypad still changes state to reflect the correct state.

@gopher.ny - Is this something you are already looking in to as part of Hub Mesh? From what I can tell, the state of the keypad is correctly updated in the keypad driver on both the HSM hub and the hub it is paired to. If I use the keypad to disarm, the driver will correctly say disarmed on both hubs, but HSM will not disarm.

For me, most of my important motion sensors and door contact sensors are hardwired and I have them connected to what I call my safety hub. It makes sense to me to have HSM running on this hub. This hub has both Zigbee and Z-wave disabled on it. Therefore, I need to pair my Iris keypad to the only hub I have that is running a Zigbee mesh. Unfortunately the keypad doesn't work in that config :cry:

Edit: I'm running 2.2.5.131 on both hubs

My best answer and the solution I am currently using is rules running on the master hub that read the remote keypad state and set the master keypad state to match the remote one. This then triggers a mode change. Its pretty lumpy but does work.