Cast-web porting help - SOLVED


#41

It can't be turned off for GH, GH mini or any of the speakers with built in Google Assistant. The "cast tone" can only be turned off for Chromecast audio.


#42

Has anyone actually gotten the speak text or speak or anything TTS other than broadcast to all devices to work? I keep getting an error in cast-web. It was working a while ago but seems to have died all of a sudden.


#43

Is working for me. I use the hubitat tts though not googles.


#44

Yeah, I'm trying to do the same. I keep getting:
dev:5302018-11-16 08:49:23.876 pm errorgroovy.lang.MissingMethodException: No signature of method: dev1542343491814217809674.textToSpeech() is applicable for argument types: (java.lang.String, java.lang.Boolean) values: [Testing, true] on line 357 (speak)

I'm not trying to broadcast to all devices, only send TTS to one through the speak command, which i was always able to do (and still can) in ST.


#45

Ah yes I had to modify a line in the driver to make it work.. Give me a few I will post.


#47

Looks like this is what I did - shows as line 412-420 in my ide. Just modified that last return line.

   def speak(phrase, resume = false) {
        if(settings.googleTTS && settings.googleTTSLanguage){
            if(settings.googleTTS==true) {
                return playTrack( phrase, 0, 0, true, settings.googleTTSLanguage )
            }
        }
        //return playTrack( speak(phrase, true).uri, 0, 0, true )
        return playTrack( textToSpeech(phrase).uri, 0, 0, true )
    }

#48

Okay..."phrase,true" changed to "phrase".

That did it!!! Thank you!!!! :+1:

And on a side note, what is the TTS engine? Some of these voices are F-ing creepy!!!


#49

sticks to my motto - whatever works :slight_smile:


#50

I think hubitat uses the amazon Polly tts or some such. Quite the variety. I like the British guy Brian...


#51

Thanks all, got this running with the edits


#52

+1 from me.
I'd be very happy to see TTS added in your Rev 1 if it'd work with a Home Mini.
:grinning:


#53

Not sure how I missed this but that's ALL I want. I personally don't play music a lot and if I do it's through the stereo which I don't care about notifications. This would be a very welcome addition for me!!!


#55

So trying to get this working. I have both device drivers up and the app. It communicates fine and returns ok but it never loads any of the devices. I made the drop down menu change mentioned above.


#56

Might have missed an earlier reply but why not use the built in Chromecast support now?


#57

Because it doesn’t seem to support slider volume whereas this does. I was pointed to try this


#58

Huh. I set volume all the time. At least as an integer.


#59

How? With the native integration the only place you can do that is from the Device edit page. To set it via a dashboard or through a rule you have to create a custom command with the volume as a parameter of the volume you want. So, one command per level. that's the only way to use the native integration to set volume.


#60

Oh I created two custom commands for the only two volumes I would ever want.
Announce: 80
Then
Normal: 60

Didn't see you were trying to do this without custom commands...
I wonder if ShapTools has any TTS functionality in their rule engine.

Edit: it appears to!


#61

How would that help you? You would still need a separate rule for each level, wouldn't you? Or does that support variables? I haven't looked at it much. I have it, just never seemed worth digging into.


#62

I suppose I don't understand the requirements.
Can't you just yell at the assistant device to set it's volume?
My ShapTools can set the volume multiple times throughout a rule without a custom commands.
They don't have global variables though as far as I see.