Can't update a hub time variable on a dashboard(Bug?)

I have a hub date/time variable that uses time only. My rule sets the time of the variable, but not a date.

I have the hub variable included on a dashbord, so I can change the variable manually if I desire. Very seldom do I have to do that. I had an occasion to do it a few weeks ago and had the same issue. I had seen a few post about a new version coming soon, and I knew there were some issues reported about date time variable usage so I thought I would wait until the update to see if it fixed the issue, it did not.

Today I had another occasion to change the variable again. The problem is you can not set just a date or a time in the variable via the dashboard, You must set both. Also when you set a time the tile switches to 24 hour format although the original time is in a 12 hour format. I can go to the hub variable in settings and set the value as I want but I can not set it using the dashboard. Is this a bug or is there some dashboard setting I need to change.

Please update to the latest version that was just released ( 2.3.1.130):

It appears there is still a bug with how this works.

3 Likes

Confirmed, just updated to 2.3.1.130 and there is no change.

2 Likes

This is still not working with latest rev 2.3.1.134.

Have you seen something in the release notes that would lead you to believe it's been fixed?

Sorry to have troubled you.

2 Likes
  • Fixed edit for DateTime Variables on Dashboards

Sorry if this is not suppose to address this but it would seem that it does, Updated to 2.3.1.135

I see no difference in how it works for me. It still only allows me to set both date and time and not just one or the other. Also after setting the date time it uses a 24 hour format instead of 12.


Dashboard before editing just time;

Dashboard during edit. I can select and edit just the time, but after doing so it shows invalid date. In the following screenshot I have edited the time to be 5:21 PM. You can't see the PM, I have tried making the tile bigger but it makes no difference.

When I hit save I get invalid date.

How the tile is displayed depends on how the variable is set. If just time, it shows just time, if just date, it shows just date, and if both, both.

You can see each of these is open for setting the value. Here are the Hub Variables for each of these:

It is not the intent that you can change from a full dateTime to just a time, or vice versa, on the Dashboard. You do that in Hub Variables.

In the third screenshot above I show what the variable looked like before I tried to edit. It is only set to time. As soon as I click on the tile it changes to only allow setting a date and time.

I created a new time variable to see if it was how I created it. I only selected a time and created the variable. QuittingTime was original and I just added quittingtime2. quittingtime2 does the same thing as soon as I click the tile I get the date time dialog, as seen in the first tile of your screenshot

dasherr6

Apparently it is some kind of browser issue. I just tried it with edge and it worked as you describe. I am currently using chrome, which it does not work as described.

I'm using Chrome with no problems. Could be something cached in the browser.

Apparently it is, because my system at work which was also exhibiting the problem now works as expected. It is also running chrome so when I get home this afternoon I will have to see what's up. It also works correctly on my IPhone now.

1 Like

Cleared my browser cache and that fixed it.

1 Like

Download the Hubitat app