Can't register hubitat with portal

I'm excited to set up my new Hubitat Elevation, but I'm caught in a registration loop when trying to register the device with the online portal.

I can find the Hubitat Elevation on my local network just fine, it has a local IP address, and its internal web server is functional. But when I follow the prompts to try and register it with the online hubitat service, it asks for my credentials, and then just brings me right back to the device's local web server which still shows the notification: "Hub is not registered, Please Register". Clicking that just goes through the registration loop again.

I already tried rebooting the hubitat elevation, tried disabling my firewall, and tried the process in both Safari and Chrome with the same result. I sent a message off to but got a reply that it wasn't business hours, so I guess my plan of getting this up and running before Monday might not come to fruition.

I should add -- here's some Hub Details in case the hardware or software version are implicated.

To clarify -- I have an activated account in the online portal, and can login to my local device, and just cannot get the process of registering it with the portal to function.

Hub Details

Hubitat Elevation™ Platform Version

Hardware Version

Rev C-5

On a hunch tried changing my 22 character password that included symbols to 8-char alphanumeric on the portal. Same result.

It was my third attempt on a third email address before it was authenticated, my other email addresses are still awaiting authentication

Welcome! Please check your private messages (click on the green message in the upper right corner, then my user name).

Hi guys,
Any solution for this? I have the exact problem

apparently the problem was from Hub Login Security. Once I've turn it off, registration completed with no other problems

Hi Gang, Same problem here. Any tips?

Unlikely to be something the community can help with.

But @bobbyD probably can.

Edit: just to clarify, brand new hub right? Not purchased from someone else?

1 Like

Same problem doesn’t describe exactly what you’re seeing.

Review the docs


Hi there, this particular issue has been resolved a long time ago. If your hub has a persistent blue light, please be sure to send us an email at