Cannot find my new Hub


I’ve just got my new Hubitat C7 and I’m having issues finding the hub as per the instructions. Here’s my setup:

  • Eero router in the home
  • Connecting Hub to switch
  • Eero detects Hub, assigned IP and MAC address(which I have reserved for Hub)
  • Hub has blue light
  • Using Chrome browser on same network as Hub
  • Tried finding using MAC address
  • Stuck on “looking for hub”

I've even tried the app. No luck.

Any help appreciated

The LED never turns green? Green means the hub is up and running, From memory, I think blue is the User Interface isn't loading for some reason.

If you know the IP of the hub, can you try to enter that into your browser address bar, followed by :8081 In other words, something like (but using your hub IP instead of this example)

What happens if you do that :8081 procedure?

1 Like

Another approach: use Advanced IP Scanner (sometimes called angry IP Scanner).


Sorry, that should read the Hub has GREEN light.
Thanks! I was able to get in with the IP and the :8081. So from here, do I do an update?

Edit: this was for a blue light, I see you got the green light. This probably isn't the right thing for you.

You should probably also read this thread I linked below, it may be the same thing you are seeing.

I started in the middle of the thread with the advice from the support team, but you probably should read from the beginning to see what was tried.

In that same thread, this was marked as the solution. Maybe this should be the first thing to try.

1 Like

Ok, I now can't seem to 'update'; it results if a 'fail'. I logged in using the MAC credentials and tried, but also am getting a fail after that too.

If you just try the IP address in the browser, what happens?

Can you try opening a web browser and go to hubitat.local to see if you can reach it?

What about trying in a private browsing window?

1 Like

It says 'corrupt data base found' and tells me to try reboot or soft reset. I tried rebooting but then it just hangs on reboot and says Hub unreachable. Yes, even in private browser window in Chrome.

Ok..soft reset worked! Thanks for your help!