Cannot find discover Hubitat Hub

I bought a used Hubitat months ago and have not been able to get it to work. I emailed support and was told "Looks like the hub was connected to the cloud a few days ago. I went ahead and updated the admin account with your email address".

I have never been able to get the hub to connect to the cloud, not sure why support thought differently. Nothing comes up when I "Find Hubs". On computer I do not have any registered hubs. On my phone's Android App I have one, "My New Hub" @, but a popup always says "Hub Unavailable". On my router's admin page I do not see my hub's MAC address.

I have tried searching for the hub thru advanced discovery using the hub's MAC and using each wired and wireless client on the router admin page. I don't see anything at "http/hubitat/". I have tried multiple different cords. I have tried multiple different browsers on Windows and Linux.

Light is green.

Hub model C-5

Have you followed the Hubitat Documentation which shows how to press the small button, on the bottom of the hub, for 7 seconds to reset the hub’s network configuration back to DHCP? That may be enough for the hub to get a DHCP assigned IP address, and allow you to find/access the hub.


Should be http://hubitat.local and sometimes it helps to reboot the router after plugging in the hub.


There are likely two issues at play here:

  1. As @ogiewon points out, the previous owner may have configured it with a static IP; hence, it doesn't show up on your network or router. To fix this, use the reset button as he indicated.
  2. It is also very possible that it is still registered to the previous owners account. If this is the case, you will have to ask them to unregister it.

That worked!!! I never noticed this button hidden under the case, and didn't find the docs referencing it. Thanks!! Much appreciated