Cannot add devices in S2 mode

I've got a C-7, the z-wave network on it was migrated from a C-5.

I'm attempting to add S2 devices, and while the device includes, hubitat won't do anything with it, see screen shot - note the last device.

I've tried this with an Inovelli switch, two Zooz switches, and a Zooz water leak sensor (shown last item in the screen shot).

I am able to add devices without S2 with no problem at all.

I've even gone into the silabs PC application and ensured I don't have any "ghost devices" in the network.

I've tried this using Smart Start and standard inclusion.

Am I missing something here?

Stealth edit: Hub version 2.3.4.116, zwave version 7.18.1

VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:18, firmware0Version:7, firmware0SubVersion:18, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:15]])

@d112 The notification sensor entry is a ghost and you should remove that one or you will have mesh issues including pairing additional devices. That said a good rule of thumb is to only pair border devices (locks and garage door stuff) with security and leave everything else as none.

Have you tried doing a full shot down and pulling power from the hub for about 10 seconds?

Also try putting the device in inclusion mode again and pressing Discover.

Smartstart should work pretty easily for S2, I have used it a bunch of times. I just scan the code into the app and then power up the device, usually includes very quickly from there.

Out of curiosity do you really need to add those devices with S2? Yes, it is more secure, no it does not create problems like S0, but it still adds overhead. If these are edge security devices it makes sense but otherwise consider going without.

1 Like

The notification sensor entry is the device I'm trying to add. I remove it, include it with security, and then it shows up like that.

Yes - I've done full shutdowns - wait until the light turns red - pull the power for 30 seconds, power back up.

Smart Start has not worked for me at all, the devices just get discovered into ghost mode.

That said, I did not try putting the device in inclusion mode again and pressing discover, I'll give that a shot.

Yes.

Just a quick update on this. Looking at the network with a z-stick, it does look like the S2 devices do get included properly into the network, but it appears that hubitat does not like them.

(Device 0x43 is my z-wave stick)

image

And there's what the PC Controller software shows.

What are those 2 devices? I would remove them through the SI software, then factory reset them. Prior to pairing shut down hubitat from the settings menu, unplug power to the hub for 5 mins (at the wall not the hub) then power back up. This will clear the radio. Then make sure you update your z-wave firmware from the z-wave settings page (click update at the top of that page) Then attempt to pair again.

What are those 2 devices?

The last two devices are a water leak sensor and the PC controller. They're just examples.

I have tried to include every single device I own with S2 - every device you see on that list - they're all Zooz and Inovelli, I think all of them are 700-series chips, and the hub behaves this way with every single one.

The only way any device will be fully recognized by hubitat is if I include it with no security.

This will clear the radio.

I've done this several times.

update your z-wave firmware from the z-wave settings page

The firmware is up-to-date (see my initial post), there's no update firmware button on that page.

Again, my guess here is that the device is being properly included into the network at the Z-Wave level - as you can see from the information displayed by the PC software - but Hubitat is failing to fully recognize it.

Are there logs I can collect to provide to Hubitat for further diagnosis?

I did an additional test. I excluded one of my switches from the network, and then re-included it as S2 authenticated. As usual, it's showing up this way in hubitat:

No hubitat device was created, it's stuck in limbo.

And as usual, it shows up normally in the PC controller:

image

Then I did a test. I am able to control the switch - turn it on and off - from the PC Controller application.

To me, this further supports my theory that Z-Wave isn't the problem here - from all the evidence that is available to me, this device is correctly included in the Z-Wave network. The problem appears to be something in the HE software itself.

Firstly I wouldn't include anything except barrier devices with encryption in the 1st place but that isn't really the issue here. I assume you are using the latest version of the platform (2.3.4.117). Let's try a soft reset.

Remove errant device.
Go to settings>>backup and restore
Go to bottom of page and click create and download. (This will download your latest back up and clean it of corruption should any exist)

Go to yourhubip:8081
Click Soft reset and follow the instructions.

On reboot you will be prompted to upload the database. Pick the one you downloaded to your pc in the previous step.

Get your hub closer to the device and pair again and see if it takes with encryption.

1 Like

Appreciate the response - I'll try that later today. Thank you!

I managed to tear myself away from work for a few minutes. I excluded, backed up, soft reset, restored, included with S2 Auth. Same thing.

The device (in this case an Inovelli switch) was included in the mesh, but not properly discovered/identified by hubitat.

When I did the inclusion, I ended up with the "The device is completing bootstrapping..." message with the "looks like you're having trouble including your device..." message after that.

Honestly I'm out of ideas at this point. Maybe @bobbyd can look at your engineering logs and shed some light on things.

Thanks for trying though! :slight_smile:

I'm happy to gather whatever logs are needed here.

Dave

If you send @bobbyd a PM (do not post publicly) your mac addr he can look at the logs

Have you screened the logs when you are trying to include a device? If the device is failing because of bootstrapping, you may need to update the device(s) firmware. Both Inovelli and Zooz early firmware had issues with S2 inclusion.

1 Like

Is it possible the migration from the C5 to the C7 with the zwave table backup somehow gummed up the C7? That was the only other thing I could think of, but I many people do this all the time without issues though. But would a zwave radio reset possibly fix it?

I have and the logs don't say anything that stands out to me. I have included all the devices with no security and upgraded the firmware in them to the latest available, because I thought that might be causing a problem.

This thought has crossed my mind, which is why I mentioned that I migrated. What exactly is involved with a radio reset? Would I need to remove all my z-wave devices from hubitat beforehand?

I don't have that many z-wave devices and they're not involved in very many scenes, so I'm willing to set aside a couple hours to try it.

You could either remove all the devices ahead of time if you want. Or you can leave them there and once the device is paired again, you can use the Apps Swap in settings to move all the attached apps to the new device, THEN remove the old device listing. I am not totally sure what happens in this case if the new device conflicts with a DNI of an old device but reportedly this is how people have done it before.

Download the Hubitat app