C8 ver. .138 zigbee is still finicky!

device stopped responding..(sylvania gardenspot) reset and pairing would fail.. would say previously paired device found but cannot control.. tried both alternate pairing methods... same result..

so then tried totally removing the device.. so far so good.

then tried pairing again
STILL says found previous device.. what the heck .. obviously database is not getting cleaned up correctly when removing a device.


2nd attempt remove device again... reboot hub... rebuild zigbee

now pairing does not find a already paired device but hangs on initializing and the new pair with keys in open still hangs on initialize.. sigh..


Same here, thatโ€™s why I do not remove anymore any Zigbee devices that have successfully paired to my C-8 one way or another.


I noticed this, times 100 when I did a double channel swap between C4<->C7 a while ago, and tried moving 100+ devices. What a nightmare. Things have finally settled down now, after about a year. I was never able to figure out the root cause, but this seems to be it, DB not purging old entries. And it brings to mind a discussion between Markus(no longer on forum) and Mike. Something about changing the Zigbee behavior around a device leaving the mesh, where the number of leave requests was changed from 1 to 10 "beacons" or something like that.

In my case every time I wanted to re-pair to either hub, it never worked, unless I shut down the other hub first.


Just curious, have you tried the shutdown and power cycle thing as well?

I think the problem is this device is at the edge of mesh and it tries to pair through a repeater and that is not working in many instances on the c8. I believe i will have to dismount it ie unscrew controller from house bring closer to hub and move back. Unfortunately i am not at that location right now as obvious by the weather station i just installed in fl.

1 Like

As i side note see the number of pings in new zigbee details.. it would be nice if this was made visible or better put the last message time as an attribute in the device so we could write a rule that says device dropped off mesh based on this.


I'm still not sure what setting pinging 'on' for 'inactive' devices gets you.

Success!!!! i got it to re-pair as a new device remotely. Here is what i did..

I already had a zigbee switch on the lights and a rule to reset them


This ran fine yesterday as evident by the lights flashing i could see on a camera
Buy they would no re-pair with the hub correctly. Used to work immediately and well with the c7.

After full removal and a hub reboot got a a hang on initialize with all 3 pairing options.

Even after this light was still not joined again as evident by flashing in camera when i turned off and on the zigbee switch they were connected to.

  1. So i turned off the switch and light was off.

  2. Started the zigbee pairing with keys in clear mode.

  3. Left it running in a web window.

  4. Went to another web window and turned on the switch thus powering up the lights which also reset them (as mentioned they would flash)

It now found them and passed initialization!

I then waited minute and hit configure in the new device and it is now working.

Hope this helps others.

1 Like

Would be interesting to test this method for pair in place when a device drops off. Usually and in this case it would fnd the device and say it was rejoined but it would be non functional.

1 Like