C8 unable to connect to WiFi

I have a C8 - running which I am unable to connect to WiFi.

The hub works perfectly well on Ethernet. It is powered from the supplied brick, and when on Ethernet does not present any issues. I have tried to connect to WiFi a number of times, via settings/network setup/wifi settings.
Header of screen, between IP address and network test link, says WiFI is detected. However, each time, I have had to manually enter the SSID, as no networks are detected. After entering wifi password, and agreeing to connect to the network, The green circle just spins and spins. At that point the hub locks, and is unavailable on it's Ethernet IP address, but it is available on the :8081 diagnostic page.

Rebooting it (from Diagnostic page, or from network reset on the base of the hub) returns the hub to functional, on Ethernet. Sometimes there is a hub alert for elevated load.

I have tried a number of platform versions.
I have tried rebooting, including each combination of rebuilding database, clearing logs and both.
The hub has been soft reset
The hub has been full reset
All of the above has been attempted on two different wifi routers, in two different locations,

I have tried a full reset, then disconnecting ethernet, and rebooting waiting for the mynewhub SSID/access point to appear, but it never has. On boot from full reset with no ethernet, The hub goes from short blue light, momentary red, off, long blue light, the flashing red/green.

I have two other C8 that were bought at the same time, and work perfectly well on the same WiFi routers.

I'm starting to think the WiFi on this hub is faulty?

Any thoughts/help gratefully received.


This suggests that your Wi-Fi network set up to transmit in dual band. The Hubitat Elevation hub only supports 2.4ghz band.

This may be indicative of an issue with your hub's Wi-Fi, but the same symptom can occur if the other hubs have been set up before you set up the dual band network. Have you upgraded the router, changed settings after you set up the other 2 hubs?


It should still be able to find the SSID being broadcast on the 2.4Ghz band and connect to it? I have connected other 2.4Ghz only devices to my dual band SSID in the past. There is a possibility that if the router has band steering it could disconnect the hub and try to force it to the 5Ghz band but it should still be able to make an initial connection on the 2.4 band.


Theoretically, yes, but we have seen enough similar incidents to warrant a warning when symptoms like this occur.

1 Like

My Wi-Fi is set to transmit two different SSID - one at 2.4, and one at 5. There are also other 2.4ghz in the area too, None are detected.

To completely rule this out though - I have powered up a spare ASUS Wi-Fi router, disabled the 5ghz band, so that ONLY the 2.4ghz is available. My phone, tablet and laptop can all see that network, and detect it as ONLY 2.4ghz.

I have just retried to connect this hub to that Wi-Fi - with the same result as before. Works perfectly well on Ethernet, but in the Wi-Fi settings page on the hub, no networks are discovered, and on manual entry of the ASUS 2.4ghz SSIS and password, the hub locks, and has to be rebooted using the diagnostic page.

I have now reconnected it to the normal router, via Ethernet.

Nope, no hardware or setting changes made to the router whatsoever. These two were set up most recently.

@bobbyD, I have DM'd you the Hub UID of the hub incase you want to check the engineering logs.

1 Like

None of the 3 C8's are able to find ANY networks by scanning, The two that work have to have the SSID manually typed in.

You have? or you will? Because I didn't get it.

Just sent.

1 Like

Please update to latest version and see if the problem is resolved:


on, Hub does not lock-up but still won't connect to WiFi.

On entering WiFi details, I get a 'successfully joined network' - but nothing more (I seem to recall there should be a 'click here and wait before unplugging Ethernet' or similar? I also tried a shutdown from the settings menu, and then disconnecting Ethernet when it was powered off. On reboot, it flashes red and green.

Hub is online, and you have UID in prior DM