C8 not recognizing activity on connected Iris Motion sensor

Migrated to C8 about 10 days ago. Most things work. But two Iris Motion sensors (V3) connect and work OK for a day or two, then continue to report connections in Zigbee logs but stop triggering recorded events or standard log entries. If I pull out the battery and then put it back in, reconnects and records activity for a couple of days, then again continues to show regular connections in Zigbee logs but events stop being recorded.

Device info: * firmwareMT: 123B-0017-10016230

  • manufacturer: iMagic by GreatStar
  • model: 1117-S
  • softwareBuild: 10016230

used with Generic Zigbee Motion/Humidity Sensor.

Any suggestions? Thanks.

@user5198 Delete them from hubitat, factory reset them, re add them., I had this prob with my v3's and the C7... Don't just reset the device itself, actually delete it from Hubitat. If when you re pair it and it says previously discovered device, that means you didn't fully delete it from HE.

Repaired successfully. Worked for a hour or so. Then as before, records in Zigbee logs but activity not updating and standard logging not updated. When turning on debug logs, get the following after trigger sensor by walking in front of it:

dev:4842023-04-22 01:34:24.980 PMdebugdescMap: [raw:catchall: 0000 0000 00 00 0040 00 12E7 00 00 0000 00 00 980DC43C15006F0D000000, profileId:0000, clusterId:0000, clusterInt:0, sourceEndpoint:00, destinationEndpoint:00, options:0040, messageType:00, dni:12E7, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:00, direction:00, data:[98, 0D, C4, 3C, 15, 00, 6F, 0D, 00, 00, 00]]

dev:4842023-04-22 01:34:24.977 PMdebugparse: catchall: 0000 0000 00 00 0040 00 12E7 00 00 0000 00 00 980DC43C15006F0D000000

Don't have any fixes, I'm afraid. But just wanted to say you are not alone. I have the same Iris motion sensor. It's the only device that's still giving me fits on my C-8. It never dropped on my C-5, and it was fine on the C-8 until the last release or two. I've moved it to a place where it's not involved in any critical rules, and resigned myself to repairing it every couple of days.

Thanks for comments. It's good to know I should just wait it out for hub update.

Could it be that Iris devices fail to register activity state changes if they switch from directly connecting to the hub to routing through a zigbee router, such as a plug? That might explain why repairing works for a while, then when changing their route through and intermediate hop, they still show up in the Zigbee logs but no longer register state changes. It's just a guess but seems consistent with what I am seeing. I tried repairing an intermediate router but I am not sure yet whether that helped. I have a small network with two routers, and in effect only one matters for the Iris devices. I have also had a failure of an Iris contact sensor which was very reliable for a few years before moving to C8.

1 Like