C8 disconnect from network

frequently I received "unable to connect to hub".
When I look in my router, it said that the Hubitat is not connected to the network.
I got a C8 version, wired connected with static IP, yes I rebooted the router.
When it happens, I tried to push the network reset pin and nothing happened.
The only thing working is to unplug the C8 and plug it again.
Then it works for a period of time never more than a day. Then unable to connect it.

Do you mind sharing a little bit more about your network setup? What router are you using, how is the hub connected to your network and if you have any special firewall policies.


There is no firewall involved. Wired connected to the router of my Internet provider Bell Hub 3000.

Static IP address.

I tried wi-fi connected to Google Nest Wifi with static ip address with same results.

There is 4 Yale Z-Wave locks defined and one Hue Phillips Bridge. I had the problem before adding the Hue Phillips Bridge.

I would try setting the hub to DHCP and reserving the IP on the router side, see if that makes a difference.

In network setup there is also this auto reconnect setting that you could try enabling once on DHCP.

If you are using a static IP (and not just a DHCP reservation) make sure that no other client in your network uses the same ip address. Based on the frequency of incidents you've mentioned, it really sounds like conflicting ips.

I made those changes thanks.

What i have done, I removed all the z-wave locks devices and keep only the Hue Phillips devices.

This morning the C8 is still reachable and working.

I will add gradually the Z-Wave locks if it this the cause.

That is likely pure coincidence. Removing Z-Wave devices would not have any effect on network connectivity. But keep us posted. Also, if it happens again, see if you can access the Diagnostic Tool. If you can, then that would rule out an issue with your network.


here is an update and my findings.

First, thanks for your advice, it was very helpful.

@bobbyD you were right it was conflicting ips. My Hubtitat was configure Wifi and ethernet. I remove the Wifi settings and it solves my problem.

Also, I applied @jtp10181 recommandations. Static ip is not configure in the Hubtitat, I configure a reserved ip in my router.

I had to change the speed from fixed 100mbps to auto negotiated. With fixed 100mbps the disconnect were there. Auto reconnect is now at 30s.

Router configuration

It has been running for more than one day. I will let it run and update you.

Is it a good practice to schedule a reboot of the C8 every day, or every week?

Sadly, it disconnected again.

So Wifi is disabled. Hub is connected via Ethernet with DHCP correct?
Auto-reconnect is enabled?
Have never heard of this happening with ethernet.

Maybe try a new Ethernet cable or a different port on the router/switch?

I am of the mindset that the hub should never need rebooting unless it becomes unresponsive. I never reboot mine unless it's for an update.

I never reboot my ST hubs or C4 controllers either.


sorry it took a long time to reply, but to be sure that the recommendations works it needs time.

The problem was that i had conflicting IP address, one reserved and another that was given by DHCP in my router. I clean up the IPs on my router.

After that I followed your recommendations, Wifi disabled, Ethernet with DHCP auto reconnect 30s and auto negotiated.

I still got the problem of disconnecting.

Then I plugged my C8 to a managed switch TP-Link TL-SG105E then the problem seems solved. It has been 3 days without problem.

Thanks for all your help


After 3 days I thought it was ok. Nope, disconnected again.

I tried to access the diagnosis tools ( 8081 ) did not work. I tried disconnect and reconnect the the network cable, did not work. I changed the network cable from the one in the C8 box to a brand new one nothing work again. I had to unplugged it and replugged it.

There is no detailed log to know what happen before it disconnect.

It does not make sense.

I got multiple devices on my network and this is the only one I got problems with.

Maybe I got a faulty unit.

I had an ISY994i for years and it never failed on me.

Does your switch let you set the port to be 100 mbps?

If the hub’s led is green when it stops being accessible, I’m still suspecting that there are jumbo frames being seen by the hub’s network interface.

But as you say, perhaps you have a defective unit. Have you opened a warranty case on support.hubitat.com?

Tagging @support_team

1 Like

Thanks for submitting the case. We checked your hub and nothing stands out to explain the issue. Please send me a private message if/when it happens again.

Thanks for all your help. I appreciate it. @bobbyD When it will happen again, I won't touch it and send you a message.

1 Like

I've been getting this issue also. I have C8 wi-fi and Ethernet configured but they're different networks, MACs etc., so it's not clearly an IP conflict. The networks are Unifi; one is in the 192 RFC range and the other a 10-net RFC network, both reserved in DHCP.

Power cycle is the only way to recover from the green light but unresponsive state. Will do that again and recheck the DHCP settings and hub network settings.

This hub and the C7 before it were reliable with some performance issues during backups but the C8 has begun disconnecting in the past weeks only, seems less than a month but I didn't take note initially as it seemed like a fluke...

Not sure what code can b0rk both network stacks or the kernel networking to break both physical networks but hopefully the team might know of such a change in recent updates. It seems to be getting more frequent over time but I can't really be sure without data... Maybe you folks can connect the dots though?


Two things that are known to cause issues and it is typically people with Unifi that have these settings enabled. One would be Jumbo frames which only effects the Ethernet connection. If a JF multicast hits the ethernet port it seems to take out the network stack. The other would be Wifi Optimization which will scan and adjust the wifi channel on a schedule. This seems to get the hub into a disconnected state and it wont reconnect on its own (I think possibly the LED will flash red/green for this one but cannot be sure).


Download the Hubitat app