C8 Crashing, need help

I’m replying to all posts here.

I am currently running 2 versions old. I was running the latest and the problem is worse.

The Hubitat is completely off the network. Cannot ping it. No route to host. It’s on Ethernet and gets a static IP. Since it’s off the net, no http works to any port on the hub (UI or diagnostics).

I have turned off every application and the hub still crashes after just a few minutes. If the hub doesn’t crash within 15, my hopes are up that it might actually be working!

All I have are z wave devices.

I did remove anything that looks suspicious, like my iPhone was a device in the list.

I don’t understand what you want me to post here. The graph of the network topology or the big long list of devices on the z wave information page. It’s several page down worth of page.

I didn’t count the z wave devices, but I assume between 30 and 50.

All this was working fine until I updated to the latest firmware on the c5. I suspect the problem is the same for both hubs - the behavior is the same.

I also got lucky and had a z wave repair succeed within seconds of the following crash.

My problem using UDM Pro and hubitat was not to use a fixed address on the UDM Pro, but do use it in Hubiat. Once I did that, I didnt have the issue any longer.

1 Like

On the z wave devices page, i see two suspicious, ones.

When i did the cloud transfer to the c8, one if my door locks wasn’t recognized. I did a force remove, reset the lock, and added it back.

This is the other suspicious one. I don’t know what it is.

All the rest look good, OK status, good bandwidth and signal.

Is there a way to force remove these two from the hub?

This very likely created a ghost device. I'm guessing that 0x3F is a ghost, and 0x40 is the actual lock that you added back.


How do i remove ghost devices?

Try the built in methods covered there first.

1 Like

So... 2.3.4.??? Need to specify

So you set a static IP on the hub itself, or on a DHCP reservation?
Did you try doing a network reset as suggested?

If the entire hub is crashing after 15 minutes it is probably not related to Z-Wave. So that info is probably not relevant right now. Not sure why you are trying to do Zwave repairs.

Also this:

Usually means it is a networking issue, not related specially to the hub. I assume this means the diagnostic tool is also unreachable when it goes offline.

1 Like

The static IP is assigned via dnsmasq running on my ubiquiti EdgeRouter X. I have been using first the C5 and now the C8 at the same IP. The C5 is unplugged, but I had been using it for years without issue.

I was able to get the remove button to show up for the ghost lock and removed it. The other ghost device will not show the remove button, after an hour of trying.

The hub ran overnight and crashed immediately on the first use this morning.

Z Wave repair doesn’t do what its name suggests. I didn’t realize that before trying the repair. I was hoping it would actually repair the network…

Any devices on the same network segment as the C-8 that use jumbo frames?

No jumbo frames in use.

I do use a netmask of and segregate the IP allocation by device type.

1 Like

First use of what exactly?

I think there have been some issues with netmask other than, but I do not think it involve the hub crashing. Although, your hub might just be getting knocked offline and not actually crashing per-se.

Any way you could isolate the hub from the rest of the LAN with a Would just be temporary to see if it still happens. Or, also if you have any old 10/100 dumb switches, and you put it behind that it would drop any possible "bad" packets. I know you said you did not have JF enabled but people have said that before only to find weeks later they had ONE client machine with it enabled. Most likely suspects are a NAS if you have one.

@bwilfong15 I have been using the same EdgeRouterX and a C5 for several years without issues.

However, it can't hurt to try fixed IP settings on the hub.

First use? Tapping a button to turn off the ceiling fan.

1 Like

That often causes more problems than it solves (probably from misconfiguration), but you seem like you know more about networking than the average user so it could be a test just to see. If the netmask on DHCP is the issue setting it static on the hub may possibly help.

I edited my other post above sorry, check that up there as well :point_up_2:

It repairs all the neighbor tables. Most useful if you move devices around or remove a lot of devices all at once.

1 Like

I do have a NAS. I'll check into it. I changed the IP to static.

I did change the IP to static using the networking settings.

Z Wave repair finds lots of bad nodes. I don't think they're bad, just so much networking going on during the repair that some nodes timeout. The devices do work.

The power light on the C8 is on. It could be that it's somehow switched to a different IP address, but I'm not sure anything I've set up is affecting the IP. I double checked to see that I don't have two MAC assigned to the same IP, or two MAC at all...

Interesting thing is now I have a "Generic Z Wave Switch" device that I never had before. I deduce that it's the outside porch light, because I can see it turn on and off using the UI. However, I already have a porch light device from years ago when I first installed it and paired with the c5 hub. The UI for that does nothing.

I renamed the old one and renamed the Generic Z Wave Switch device to "Porch Light". I don't know if I want to remove/force remove the non working one. I don't want to make more of a mess of the Z Wave network than it already is.

EDIT: Z Wave Repair on just the one (old one) node fails.

EDIT2: And the remove button appeared but I was unable to remove it. It stays in the list with the remove button after clicking remove. This one:

But the one ghost remains. This one:

That can happen especially if there is other things going on with the hub, and repeated full mesh repairs will only cause more problems by spamming out tons of discovery packets.
For now I would maybe not worry too much about Zwave but when you get the hub stable, you can make note of which nodes fail and then do those one by one to see if they will repair that way. If it still fails then possibly the hub cannot reach that node.

You can try the advanced discovery on here: http://findmyhub.hubitat.com/
Most likely though is that something within the LAN is upsetting the interface on the Hub and knocking it totally offline where only a power down can bring it back. It has been proven to be especially sensitive to multicast JF packets. Not sure if there are other things it does not like.

That's why I suggested to totally isolate it, which if done correctly would rule out any possible LAN issues.

The odd thing is that the C5 worked for 3+ years with the Ubiquiti gear.

A bit more info.

I am using the Maker API to create a Hubitat <-> MQTT bridge, and it worked all night long until the first attempt to turn off a device (fan). There were MQTT messages right up until the crash.

Yeah, unless a software update on the NAS changed something and now it is sending out multicast JF for some reason? Or even a software update from Ubiquiti, I have seen other posts where people said a Ubiquiti update started causing issues due to some change they made. Could be any new piece of equipment you added or anything that was updated :frowning: . Assuming it is a networking issue. Not saying there is anything wrong with your network, but just something that is not playing nice with the HE Ethernet interface possibly.

Another thought, since you said it usually goes down pretty quickly. If you want to rule out Zwave you could just disable the Zwave radio for a short time? I cannot recall though where anything Zwave related would cause such a swift and severe problem.