C7 z-wave problems, coming from bulletproof Vera3 UI5

C7 (added devices under old firmware, but upgraded to current and trouble started)
Current FW =
Previous FW =
Current Z-Wave = VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:14, firmware0Version:7, firmware0SubVersion:14, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:18]])

So I have older Z-Wave devices, not sure if anything is Plus except a couple things. Mostly Monster (Leviton) dimmers and scene controllers. Everything included great under the older FW the C7 came with, but now nothing works at all, I went through and tried to follow several suggested fixes, reboot with database rebuild & no change, but I do see some "dead" devices now and can't remove them. So it is best to just wipe it and start over excluding/including with the newer FW? I don't think any of my devices power report, maybe the battery garage door sensor, but I can't see how to turn it off. OR is C7 the problem and I need the C8 PRO for direct no-hop as it is on sale this weekend? Wife is ready to hang me by the Cat5, ha ha. Many thanks, I've been out of practice with a working Vera for years now. Tried Hubitat in the hopes it would be better for me after playing with HASS triggering Vera.

You could try going back to that ver. http://HUB-IP:8081


Then try ; reboot with database rebuild

That is likely the issue. I suspect that the platform update is only coincidental.

“Dead” z-wave devices (we call them “Ghosts”) will cause major issues on your Z-Wave mesh. They absolutely must be removed. Usually they are caused by a device that didn’t pair correctly the first time, and it eventually works after a few tries. So the working device should be a few devices down. That device must be powered down for the removal to work.

1 Like

Thank you, I was trying that and your post confirmed I should be. That FW's reboot doesn't seem to have a check box for rebuilding the database. Seems to still be behaving the same way with the original FW restored, just no action in logs or z-wave.

The Z-Wave version seems to be the same? VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:14, firmware0Version:7, firmware0SubVersion:14, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:18]])

Should I try one of these options:

Thank you, they weren't dead under the old FW. But still are after the 'Restore Previous Version'.

I am not sure what "kills" the z-wave chip in a device, but I have had one of these dimmers "ghost" itself with Vera in a 4 gang box of other of the same dimmers, but I blamed the LED bulb load itself or box fill causing overheat. But everything was working well, I carried the Hubitat around and had it sit a minute or two with each inclusion to be sure it got all it needed, but I realize it is all blind and I assume they fully included. I can't find my old Aeon stick I used for quick exclusion, but I will keep looking, I might try using Vera's buttons for exclusion of the ghost devices.

1 Like

Just as an update, there doesn't seem to be any action at all. It's not latency or a busy network per se, it is just not doing anything where before it used to show an action executing at the bottom of the device page for a device.

My next step in this situation would be to shut down the hub, remove power for 1-2 minutes, then start it up again. This will reboot the Z-Wave radio (it need the power pulled to truly reboot).

I had a single ghost I discovered on my mesh last night after I noticed automations going south. The ghost wreaked havoc on my mesh/automations. It wasn't created by a failed pairing in this case, just a device (blinds motor inside my metal blinds housing) that decided it was tired of working so hard to talk to my hub from its Faraday cage. This one ghost ripped up my mesh. So not trying to pile on, but clearing up the ghosts is critical.

Assuming you're on, you're up to date in terms of platform version. Run this to confirm you're on the most recent Zip gateway version, I expect you are:

  • hubIPaddress/hub/advanced/zipgatewayVersion

You should get the response: 7.18.3

Assuming you're up to date, see this post on removing ghosts. Start in section 3 which covers using the hub's built-in ghost removal tools.

1 Like

Can you post your z-wave details page in it's entirety? (use windows snip)

1 Like

Thank you all, I tried rebooting several times. I ended up trying the FW upgrade under advanced and am now on I wanted to post my Z-Wave details here before I removed the recently ghost(ed) devices. I did have the Polling App added to the working system and had since removed it thinking it was clogging the network. I am OK with updating firmware to the latest and re-including everything, but is there a better FW for older Z-Wave devices or do I just keep it on the latest?

Where I had 1-2 ghosts, then 4, and now it shows 5, so I hope something isn't physically damaging these dimmers due to over-polling or something. I really want to avoid replacing all these aside from the cost. Many thanks. Sorry I couldn't scroll capture it so 3 pics below. Route column didn't have any blanks when I set it up. I had done a Z-Wave repair on the original working Hubitat and I think that's where my trouble started, then tried individual repairs and it got worse.

As an update it doesn't remove the device using the Remove button after Refresh to expose it, but I do see it still talking to the thermostat in the logs.

Just to clarify, rebooting won't help w/your Z-Wave radio, you have to shut down, pull power, wait 30s, and then plug the hub back in again. That process will "clear" the Z-Wave radio. Doesn't remove any devices or data, just refreshes the radio.

The current platform version is, you should update to that version. Settings>Check for update, and update to the current version.

You have a bunch of ghosts, and will need to work on them. You may be able to remove some of them using the hub's built-in ghost removal tools, but in the end you might have to get a Z-Wave USB stick (aka UZB stick) and remove the ghosts using a more complex process, unfortunately.

Good idea to disable your polling app for now, as that puts extra load on your mesh.

Your devices aren't being harmed, they are just not communicating effectively w/the hub, and vice-versa. So no device damage, you don't need to worry about that.

I would update to, do the shut-down/pull power/wait 30s/plug back in and re-check what your Z-Wave Details page looks like to see if any of the devices look normal again. That might happen, but no guarantees.

Then to start working on removing the ghosts you need to do as I said above and look at the ghost removal topic...

Assuming you're up to date, see this post on removing ghosts . Start in section 3 which covers using the hub's built-in ghost removal tools.

Thank you for the help, some of my reboots were full power off cycles. I will try removing the ghost devices, even as an experiment to learn, before I try starting from scratch with updated FW. The fact that the Thermostat is still in the logs shows somethings are communicating where it seemed dead.

The "harmed devices" concern comes from me having 2 of these dimmers "go bad" or stop communicating in the same location in the switch box with the same load. Vera3 UI5 must have had a better way to handle Ghost devices since everything still worked around them even when left in the UI and not excluded. But I know it was a long road for Vera developers to get it to be rock solid.

Certain Leviton are sorta known for being troublesome on some (Leviton) firmware. Not sure if these are up to date, or even can be updated, but this might explain some of your issues...

From what I understand, there are even Beta firmware for certain devices that aren't listed on their download portal. You may have to contact their support to receive these hidden updates. The below two threads cover a lot of this information.

It appears you may also be out of date with the Hub Z-wave. Note, this is not the same as the hub firmware updates.

I think you should be at

VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:18, firmware0Version:7, firmware0SubVersion:18, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:18]]).


Yes, get that z-wave chipset firmware updated. That is going to solve a lot of issues. I went through that myself a while back and its a huge difference going from the launch z-wave firmware to the current on the C7.


Dang, how did I miss that! Reading too quickly for my brain to process again. Good catch!

1 Like

Thank you, all the Leviton dimmers were working fine under Vera aside from one, I was just trying to say that the one that stopped responding in Vera didn't gum up all of the others from operating and reporting. I'll see if they can be updated, but they were all purchased at the same time with matching in-wall scene controllers that allowed associations for direct control. Dimmer class is one of the simplest of Z-Wave device classes, it is a shame that there needs to be FW upgrades for them to continue to work.

I will do the Z-Wave chipset update first, thank you. Hopefully it helps enough that I can leave the Leviton device FW alone unless it is not difficult or that risky to upgrade.

I also remembered that even though I have unplugged Vera3, I still have a room of 2-3 devices that are on that old Vera network, they are working between themselves via association as a "3-way" with a switch on either side of the room to the same light. Those wouldn't be impacting the new network would they of on different house code, would they?

They wouldn't have released firmware if it wasn't needed. Again, many users have observed issues with certain Leviton devices.

It isn't very risky, but it can be somewhat time consuming. I would consider trying the update on 1-2 of these after doing the Z-wave radio update to see if things act different or better.

Probably not, but you could maybe do a temporary power down of this hub to see what happens if you continue to see problems after doing these firmware updates.

1 Like

Understood, all good points and your time and input is very much appreciated. Sorry for whining about FW ha ha.

If I can get to a healthier system with less latency that is ideal. I guess I am still leery from my years and years with Vera ups and downs and new FW woes.

It seems to have finally successfully started updating the Z-wave FW, and says "success, please reboot", then after reboot Firmware Update seems to be transferring FW slowly. I will make sure I am on the latest Hub FW after it finishes. I'll update poste here after looking to device updates.

Edit: night and day difference, devices respond, the hub responds. I only show 1 device with empty route column now, it's the front porch light who only had the door lock and hub itself as neighbors so I may exclude and replace that one. THANKS!

1 Like