C7 platform C5-C7 inclusion differ

Having trouble adding a GE 4201 Zwave WP plug. It joins to my C5 fine and even sends On/Off without polling or refreshing when manually controlled. When I exclude it from the C5 and try to install it on the C7 it is troublesome. And when I do get it connected using built-in type "Generic Zwave Outlet" it will turn on and off from the device page, but no notification to the controller of manual operation. Same driver, why would it behave differently?

@2ac16mo Generic z-wave outlet is correct for that unit. Which version is it? If that isn't a z-wave plus switch (12720) and therfor won't display status properly. You need to install z-wave poller to have it update properly. That brings be to wonder if you already have z-wave poller installed on your c5. If it is the z-wave plus version (14284) , turn off your c5, factory reset the outlet then pair it right next to the hubitat. See if that helps.

1 Like

One switch is GE ZW4201, date code 0934 and vers 3.0A
The other is GE4201, date code 1317 and vers 3.0D
They are both joined to my C7 hub and defined as Generic Zwave Outlet.
They both work fine from the device pages.

My experience has been that SOME Pre-Zwave+ devices do report state changes to the hub. For example most of my Cooper RF9534 dimmers report on/off/level changes immediately and they are not Zwave+. They have done this on a C4, C5 and C7.

My guess is that at some point before Zwave+, manufacturers changed the firmware to include this reporting feature. Could have been due to anticipation of Zwave+ and/or expiration of some copyright.

My main question is why does one of these devices report state changes to the C5 hub, but not to the C7 hub? I'm assuming there has been a change to the C7 that is causing this.

Edit: I do not have the Poller app installed on the C4, C5 or C7. Sometimes I use a periodic rule to refresh older devices.

Do you get on/off status on the C7 when you manually control the device?
What do you see in the stats on the z-wave details page for the device (on the C7)?
Does the z-wave details page show errors or devices that failed inclusion?

There are many possibilities for the experience you are describing, but the most common in this scenario is probably that the messages are not getting from the switch to the hub.


No, I do not get on/off status change on the C7 when manually changing the switch. I did on the C5 (with one switch only)
No errors or failed inclusion on the Zwave Details Page. Both devices are included and can be controlled from the Device Status Page.

Just really odd that the device when on my C5 hub does send the on/off to the hub, but not on my C7. Not a big deal, just thought perhaps something changed in the generation of hubs.

What does the rest of your z-wave details page look like?


FYI - GE sold z-wave and z-wave+ versions of this outlet under the same model number (GE4201).

Here's the z-wave+ version


Here's the z-wave version

So @2ac16mo, I'll bet you have one plus version and one non-plus. However, as you are using the non-plus driver (Generic Z-Wave Outlet), the plus version isn't reporting back to your C-7.

You probably used two different drivers on your C-5.

Anyway, use the Generic Z-Wave Plus Outlet driver for the plus version. And click "Configure" on the device page. It'll start reporting as it did on the C-5.

1 Like

Well sir, you had me all excited there for a few minutes. I tried assigning Generic Zwave Plus Outlet to both plugs (even did Generic Zwave Plus Switch). The one which is v3.0A will not operate with that driver at all. The v3.0D does work with that driver. Unfortunately v3.0D does not report state changes with that driver. So it will remain a mystery why it worked on my C5 but not my C7. I thank you all for your suggestions and advice.

1 Like

After you saved when you changed drivers did you click configure?


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.