C7 Hub update failed [Solved]

I'm new to Hubitat over the past week, and have been attaching more and more of my devices to us (from SmartThings). Well I have about 40 devices on it and working almost as I want it to.

Well, I got a notification that there's a Hubitat SW Update, so I decided to do the update... well now my hub isn't coming back online. I don't see it attached to my Alexa accounts, I can't get to the web GUI, I can't find the IP, nothing.

I knew it was a mistake to do the SW update, but seriously, if this doesn't come back online I am going to be returning this new hub BACK IMMEDIATELY.

...sorry, I've already had a really long day and this has been the freaking cherry on top...

There are several threads about this happening, sounds like the Beta test didn't quite have a large enough pool. Do some reading as many people have been able to get their hub back by various methods. I can't help as all three of my hubs updated fine, so I haven't read the threads that close.

Just letting you know.


@db1 - could you try this?

The documentation for the Diagnostic Tool is here:


Thanks, I received a response back from one of the admins about it and they helped me through reverting. I'm going to post those instructions on here incase this happens again and I need to find it.

Bobby Dobrescu
Dean Berman hi there, sorry for the inconvenience. We have identified an issue with some hubs not starting after the update. The incident is not critical and there is no loss of any data, but nonetheless it's frustratin. Here are some things to try to bring the hub back online:
Go to http :// your.hubs.ip.address:8081/
Reboot the hub from there, see if it comes up.
If not, go to http :// your.hubs.ip.address:8081/ again, revert to previous version.
After it comes up, go to http :// your.hubs.ip.address:8081/ yet again and "revert" to version 2.2.5.
It's possible that 2.2.5 is not showing as an option at this point. Use Download latest version to get it onto the hub. Doing so doesn't switch to the downloaded version, so once download is done, use revert option to switch.
If it still doesn't come up, revert to previous version and let us know. We'll have a fix shortly


Maybe the release will include the fix for the DNS issues... :slight_smile:

1 Like