C7 - Corrupt

Hi All

Please can someone get me in touch with the Support Teams?


When I hit "reboot the hub", it seems to reboot-light goes to blue, etc. But nothing on the "diagnostics tool" link works.

  • Cant update
  • Cant restore
  • Tried shifting versions
  • Tied numerous Soft Reboots
  • Tried a Platform Reset
  • Now in desperation a Full Reset

Still not working... What is next please?


Welcome to the Hubitat forums!

You were quite a bit out of date for platform (almost a year of updates). Also, I think you are behind on Diagnostic Tool also, which could be affecting how you are backing up and restoring etc.

Was this a new/unused hub, or were you just not doing updates? Was this an active hub with devices and rules on it?

That isn't good to do, whatever you had on there was lost when that full reset was performed. Unfortunately, there is no way to recover from a full reset, which is why it is now a hidden menu and why it is only recommended to be done from advice from Support Staff.

Hopefully there is something @bobbyD or other support can do for you.

1 Like

@ehoy Go to youhubip:8081 (diagnostics tool)

Do a soft reset instead and see if you can restore from one of your backups on board. Do you have any pc based backups?

1 Like

Never run Full Reset, it only makes things worse. Not sure what you mean by "nothing on the "diagnostics tool" link works"? In cases when the database is corrupted, only thing that works to recover the hub is performing a Soft Reset with backup restoration:


1 Like

Does it ever go back to green? It should. If you see alternating between blue and green without an intentional reboot, you might want to try a different USB power adapter just to see if that is the culprit. The one that came with the hub should work, otherwise any 5V USB power supply should work as long as it can output at least 1 A. (I do think they've recommended against Apple chargers in the past, so maybe avoid that, but anything else...)

Might be worth trying even if everything else looks OK, too! It's easy enough to rule out. :smiley:

1 Like


Missing Diagnostic Tool

The following two steps are required if you you do not have the newest Hubitat Diagnostic Tool installed, or otherwise don't see the Download Backups option when accessing it from port 8081.

  1. Navigate to http://[Your Hub IP]/hub/cloud/updateDiagnosticTool and it will install the latest Hubitat Diagnostic Tool.
  • NOTE: Replace [Your Hub IP] with the IP address of your hub.
  1. Proceed to http://[Your Hub IP]:8081 and then continue following the steps in this document.

Good thinking, but the OP is running the most current version:

1 Like

My bad, I saw another post but didn't scroll back to the original. Never mind!


Hi All,
Thank you very much for your time and suggestions! I'd like to get back to using my Hubitat.
Yes its very behind on its updates, it failed an update last year and new baby left it forgotten for a quite a few months :smiley:

Just answer to some questions

  • It was an active device, had connections to my Ring, Hue and Aeotec sensors/switches.
  • It failed during an update last year, and I just never got around to fixing till now.
  • Using the supplied Power, The LED does always go back to green and the Diags tools page always loads.
  • I cant get to diagnostics update page suggested http://[Your Hub IP]/hub/cloud/updateDiagnosticTool

I will retry the Soft Reset and restore again using bobbyDs suggestion


1 Like

Hi All,

Have done soft reboot, Sitting at same screen as before.

When I try go to "Settings" I get the following after a minute or so,

  • How can I do a DB restore from this point?
  • Anyway to force an update of the OS? I get this update failed option pretty immediately
  • Is the local storage full maybe?

Update: On a positive note... I retried the Diagnostics update URL again and got a result.

Thanks All,

Just some data from my Unifi Network, not sure if advances the discussion

I am wondering if a Soft Reset actually occurred. Soft Reset removes ANY db... thus there's nothing to be corrupt. It's empty.

I full Soft Reset will require that you enter a MAC address (as a pw), type in the words "Soft Reset" and then watch the Hub chew for a good 5 mins, before displaying the progress bar of a reboot. THEN you end up on a green screen. STOP THERE, don't install a DB, go directly through the Registration/naming/initial setup and land on the main menu screen.

Your Hub will be exactly as it was when you slid it from its box on Day 1, after registration. No Rules, No Apps, No Drivers.

Screen Shot 2022-06-02 at 11.32.09 PM

That is not what you want to see. It simply means the "password" has timed out and you need to logout, login and enter the MAC address again:

Screen Shot 2022-06-02 at 11.33.43 PM

THEN when you type in Soft Reset, you get:

Screen Shot 2022-06-02 at 11.34.24 PM

You go through this progression:

Screen Shot 2022-06-02 at 11.36.03 PM

Screen Shot 2022-06-02 at 11.39.00 PM

Screen Shot 2022-06-02 at 11.39.09 PM

Screen Shot 2022-06-02 at 11.39.27 PM

1 Like

Hi there,

Thank you very much for that specific step by step... @Support can we update the docs with those extra little steps please?

I have tried again...

and then it sits like this..............
I never get any of the steps below,


  • Kept my eye on LED, looked to stay green whole way through.
  • The base URL/site became unavailable "ERR_CONNECTION_REFUSED"
  • Taken 12mins thus far nothing changed. Will update when changed


Thanks All

3hrs still nothing ....

Can confirm the Shutdown option works :smiley:
... LED is now RED

download advanced port scanner (free) and scan your network after the soft reset and see if you can see the hub. Use the direct ip address to login to it. Does it have access to the internet?

Hi All,

Powered on, Back to this screen

@rlithgow1 I can see the hub on the network, I know its IP and MAC from my UniFi. and from the web session posted above and the diagnostics page on 8081

I just need the magic reset switch... is there a hardware one? @support happy for all config to be gone and start again... Wasting more time in this continual loop, than setting up again I think.


See that's the thing, the fact that it's coming up with corrupt database indicates that the soft reset is not being done. So weird...

Hi, Yeah I have asked it to do "soft reset" again... and its just not responding to that command I have ping -t going on the side and no drops