C5 zwave stops with only 2 Devices connected

Hi all,

Having a strange problem on a C5 hub, recently the zwave has been stopping for no reason. After a reboot all works fine but after a while it stops. I have been keeping up with the updates so not sure it that might have caused something ?

Anyone else seeing the same problem ?


1 Like

When you say "the zwave has been stopping" do you mean that both of your zwave devices stop responding to commands issued from the devices tab, they stop working in rules, the zwave radio shuts off, or something else?

1 Like

Thanks for the response, its a strange one. The two devices I have on the device are fibaro 1. Fibraro Implant and 1 Led strip.

When it stops working the zwave settings page shows no devices and the implant sensor stops sending / receiving temp settings, however the led strip comes on.

If I reboot the hub everything appears again and works, the last time it ran for about a week but this time 4 days and the only thing that happened in or around when it stopped working was that I rebooted the C7 device which is connected via a mesh.

Wow... the devices totally disappear from the zwave settings page? Do they disappear from the devices tab as well?

I'm wondering (but admittedly guessing) if this might be an indication of database corruption. A backup to a local file followed by a soft reset and a restore might help (or might be a waste of time but likely won't hurt).

yep they just disappear completely, you can still see them from the devices page but if you try to refresh or do anything with them nothing happens.

I tried disabling the zwave and enabling before a reboot with no change, I was thinking maybe temp as it can get warm where the hub is but the strange thing is one device still sort of works.

I only use this hub for integration and the C7 being the primary for all my main devices which is working fine, I did add a few apps recently which I don't normally do. I have now removed them all but one (MQTT client) If it happens again I will remove this app also.

I would like to get a look at the zwave logs on the device just to see why it shutdown the zwave, also I could be wrong about the zwave stick shutting down as the only real information i have that points at zwave is the settings / zwave being blank.

I wonder if a restore will do it, should I restore from a known good backup or just grab a backup now and restore ?

I also dropped a quick email to support just to see if they could do a quick remote diagnostics and shed some light on the problem from the logs, @bobbyD might be able to work some magic. The C5 hub has been solid however it is getting on in life so maybe i need another C7 :smile:

Have you tried shutting down the hub, and removing power for 30 seconds? This will reset the zwave radio on the C7, not sure if the same thing happens on the C5. When you yank the power do it from the outlet end, not the delicate little micro USB connector on the hub.

Rather than just do a restore, I think you need to do a soft reset after you download a backup locally. Apparently when the backup runs, the backup itself is scrubbed for errors. By doing a soft reset you wipe the database and ensure a "clean" restore. Just doing a restore does not necessarily have the same effect if the database is corrupt. Though maybe this is more of a zwave database issue than an HE issue? Not sure.

1 Like

Also Zigbee is still on however I don't use any devices.

ah ok so

  1. Backup the C5 / download a few copies of the database
  2. Perform a soft reset
  3. Restore one of the backups ... and pray.

I can give that a go, If I have to hard reset and rebuild that's fine also as I only have two devices. its really the app integration will be the problem.

I might give it an hour or two just to see if Hubitat supports gets back to me, I'm not sure if a soft reset might wipe the logs also.

Sorry, yep I tried the shutdown and wait I also removed the USB stick just to be sure. I left it off for about 5 / 10 minutes.

I also ran a repair on the zwave network after the reboot, SO maybe that might sort :smile:

I dont believe a soft reset will wipe the logs...

I doubt repair will help. Based on your description, you are likely dealing with a hardware malfunction on the stick side. Disappearing devices on Z-Wave details page, usually means that the radio went offline. Will follow up on your ticket shortly.


@bobbyD Thanks a million, anything you can share would be much appreciated. I'll leave the hub as is for now and see if you can spot anything in the logs.



@brad5 Looks like it might be hardware, I'll post back when I have an update just incase anyone else has the same problem.

Thanks for the suggestion and the help

Yeah I saw the comments. Bummer if it is but at least you're on the path to a solution.

I've just come to this thread with exactly the same issue with my C5 ( the Z-Wave devices stopped responding completely at approx 12pm UK time, the Z-Wave page on the hub showed the devices in the list, I rebooted the Hub via the Web GUI and now the Z-Wave page is blank.

I then did a complete power cycle (shutdown via Web UI), remove power to Hub, wait 2 minutes, then power back up brought all the devices back again:

Wonder what is causing it - let me know if there's anything I can post to help diagnose.


Oh that is strange is this the first time its happened to you ? Would you have a C7 hub running at the same time with mesh enabled ?

You appears to have a lot of devices connected where I only have 2, was automaton still working for you ?

No response from support just yet but I'm sure they will have a look at some point over the next few hours.

screenshot of the devices missing from the settings/zwave is 100% the same for me

I wonder might it have anything to do with an update we applied ?