C4 locked up solid -

Normally I reboot my C4 every day, but for the past 10 days I haven't done it. Today at around 6pm no automations were working. When I tried connecting to the C4 hub could not connect. But I was able to get to :8081 and reboot - which took nearly 10 minuutes.

I'm curious what this log entry means and if it is the reason the C4 locked up.

Never saw one like this before:
dev:23532021-04-14 05:51:32.395 pm errororg.quartz.SchedulerException: The Scheduler has been shutdown. (parse)

It is good to share the HE firmware version you are running...

Likely it ran out of memory/swap.....

I find 2.2.6 to be worse for this than the previous few versions....

Platform 2.2.4.158 Would you think that would be a fatal error - one that would halt the hub?

I have 2.2.6.137 on my C7 experimental hub.

Funny because I have been deleting a bunch of stuff from my C4 including rules and addon apps. I haven't added anything new in a long time. I did have my C4 auto reboot at 4am for more than a year, but was hoping maybe that wouldn't be necessary any longer.

Without data, hard to be sure.

This can provide data, I don't recall the minimum fw version to use it:

I’ve only tested 2.2.5 and up, but it may work on 2.2.4. Need 2.2.6 for the CPU load data, but the memory endpoints may have been available in 2.2.4. Let me know if you want to try it - HPM has been told that 2.2.5.131 is the minimum but I can change the manifest to allow earlier in a matter of seconds.

First time ever I saw severe cpu load on my C4, then realized my auto reboot hub rule hasn't worked since 1-26-21, not sure why.
POST: http://192.168.0.92:8080/hub/reboot; is what I use
Firmware 2.2.5.119

in more recent firmware editions, I have found a 'restart' option to be iffy

'reboot' has been reliable.

Don't know which you are choosing.

Download the Hubitat app