C-7 Won't connect on startup - site can't be reached

I am just setting up my c-7 hubitat. I was able to discover it through the hubitat portal while connected on the same network. I also found it on my onhub router and reserved its ip address.
The problem is that when I try to connect to the hubitat by clicking the link in the portal (or typing the ip address) I get the long error message
"This site canโ€™t be reached http://(ip address on my network)/loginCallback?token..."

Moreover, when I plug it in, I do not see any light come on at all.
I also cannot connect to the maintenance portal.
I have tried to connect on several devices, all with the same response.
Any help would be great.

Do you have another USB Power Adapter you can try?

Try just typing in http://ipofhub

1 Like

if there are no lights on.. i imagine what your are seeing in your net by ip is not the hub and your are confused.. it sounds like it is not getting power and not booting up. or it is toasted

1 Like

Tried right away, and also verified power supply works on other device.

That gives a simple "site can't be reached."

Paging @bobbyD. With no power indicator it sounds like a faulty hub.

Without lights, dead unit or bad power supply was my first thought, but then it showed up on my router as a hubitat device at the right ip address, and on the portal. I was able to verify the power supply worked on another device.

Confusion is always am option, I am new to this system. Here is a screenshot of what I see when I think it has located my hub.

I think you have a hub with burned out blue LED color and it may not be properly formatted. Please send us an email at support@hubitat.com , if you didn't already.

1 Like

Will do, thanks. That would explain the wonky behavior.