C-7 Hub not responding

"no response from hub" is something I'm getting used to seeing. No smart devices work for a day or so... then, it comes back online at some point. (Usually) I try power cycling, restarting my router... nothing seems to kick it back online. LED is green, but nothing is working.

What does the log show for the times that it wasn't "responding"?

2 Likes

Do you have a DHCP lease reservation for the hub to ensure that it’s not changing IP?

2 Likes

are you able to access the diag menu? http://{hub addess}:8081

3 Likes

First of all, thank you so much to you three for being willing to help me through this. It has not come back online since I posted this topic.

I'll answer in order:

-No access to any log, since it's not yet back online. (LED still green, however)

-I don't know what that means or how to check for that, however since I've been using this hub (6 months or so? Whenever the C-7 was released) it has maintained the same IP, that I know of. When I go to the "my hubs" from the portal, and seen my hub pop up there, it has always had the same IP, I believe. Also, it's a shortcut as that IP, which has always worked.

-No. I typed that in, and I got a "this site can't be reached" which I will attach a screenshot of, if it works.

The hub has worked relatively flawlessly for several months, and this has just started within a week.

Thanks again for the help!

-Lee

I hate to ask this question, but are you sure your phone is on your 192.168.1.xxx network?

Are you able to connect to any device on that network? Is it possible that you aren’t on a WiFi network that has a route to your hub? Have you tried connecting to your hub using a computer hardwired on the same network?

Just wanted to make sure these troubleshooting steps hadn’t been overlooked.

1 Like

Hey, no questions are off limits! I am indeed on the correct wifi network, and I've been trying my laptop on that wifi, and my phone which is on that wifi. Just for fun, I've tried the 2.4g and the 5g broadcast signals from my router, which the hub is plugged into.

If you're on a Windows machine, open a command prompt and type "arp -a" without quotes.

On Linux, get the arp package installed and use "arp -n"

Look for your hub's MAC address in the table, and if you find it look to see which IP address has been assigned. If it's not the same as the address you expect, you'll need to dig into your DHCP server documentation (usually people use the DHCP server on their home router) to figure out how to reserve a specific address for a particular MAC address.

2 Likes

Use either Safari (MAC) or Edge (Windows) to go to portal.hubitat.com, and then try the FIND HUBS option.

There is an issue with CHROME where it no longer can FIND HUBS, it just spins forever.

3 Likes

That got my hopes up, ogiewon. I was using Chrome. However, now I'm using Edge to test, and it's still not showing up. I'm about to try the "advanced" option and feed it the MAC address to search for it. Wish me luck.

But before that, there's a development! It's now showing up on my phone App and devices are responding to commands from there.?! Since that's now back online, I can confirm that the IP address showing up is the one I've been expecting. However, when I go to the "Hub Diagnostic" on the tools tab, it looks like a broken link, and nothing appears.

OK, a couple steps forward and a couple steps back...

I used the "Find by MAC Address" option, and it immediately found the hub, and displayed it as being at the correct IP address...

However, when I click on that hub it brings me to a dead page.
"This page isn't working right now."
"ERR_EMPTY_RESPONSE"

(status LED still green, just FYI)

OK, we've got some strange developments...

I change my laptop's wifi back to the 5g, and I rerun the "arp -a" that @eppower suggested, and this time.. lo and behold, my hub IS there now! Which... why?? My hub is hardwired into my router. And in a strange twist, the IP address does NOT match the one that it claims to be everywhere else, (like on my phone's app)

I use this new IP address and I type it in to get to the hub via my laptop's browser, and voila, it's there. So, whoever suggested that the IP is switching on me, I guess takes the cake.

Now... to fix that...

2 Likes

Arp tables are cached on most devices... I'd bet money that if you flush those tables you'll find all your devices will discover the new address mapping. Fingers crossed that your router's DHCP settings allow you to reserve a specific IP address lease for your hub's MAC address...

1 Like

Well, I'm trying to connect to my router's configuration page, but that's now been a whole new issue. I have a TP-Link Router, and I have an app on my phone (Tether) where I access that configuration... but, now it's finding it and saying that the app no longer supports that router. And via my web browser on my laptop, it's telling me I'm not connected to the router. I may be able to connect a hard-wire and change that, though... I used to be able to change my router settings so easily, I'm not sure what's happened.

Chocolate.

3 Likes

Download the Hubitat app