C-5 is losing network connection

I've seen some other threads on this problem. Like others, I've put a WiFi plug on the hubitat and I am rebooting very frequently. Sometimes it's days.. sometimes it's minutes... but the device will fall off the network.

The logs show that the Hubitat is still online and talking to the z-wave devices (polling is working and so forth)
Set as DHCP - I checked for duplicate IPs on the network, there are none.
I've set Auto Reconnect to 30s
Auto negotiate is off - set to fixed 100mbps

None of this is helping, I must reboot very frequently. I've done it twice in the last hour. It seems that this is a frequent problem - is there a resolution? I see posts as old as 2021 with the issue.


You should turn that on.... What kind of AP are you using?

Do you have any devices using jumbo Ethernet frames on the same network as your C-5?

These are known to knock the hub’s network interface offline, while leaving the hub functional - so zwave and zigbee devices will continue to work.

Many threads say to disable auto negotiate if you are having problems with connectivity.
The hubitat is connected to a Linksys WRT1900AC running DD-WRT in AP mode

I have not set anything to use a jumbo frame- Everything is set to "Auto" or 1500.

That rules out that possibility. Have you tried a soft reset? I guess it’s also possible that you have a C-5 that is undergoing hardware failure.

I am not sure what a "soft reset" is for a Hubitat... it just fell offline again... that makes it 3 times in 30 minutes.

Soft Reset | Hubitat Documentation.

If that doesn’t fix it, I’d suggest changing the network cable and power supply. And if it still freezes, you’re probably looking at hardware failure.

I will follow this procedure now and see if this resolves it.

1 Like

For lan it doesn't apply to wifi... And it's almost never needed. The reason to change it is if you have an off brand switch that doesn't adhere properly to auto negotiation and can't see the duplexing properly. In some cases setting it to fixed can cause problems with normal switches. In general the rule of thumb is to let them work it out with auto negotiate and as I said, that doesn't apply to wifi.

What wifi adapter do you have?

What channel is your AP on?

He has a C-5 directly connected via ethernet to his dd-wrt router, doesn't he?

I am not using WiFi.

Perhaps my use of AP mode was the confusing part. The WRT1900AC runs as a network switch and wireless AP. The routing functions are all off as my provider requires that I use their router.

Yes, I do.

I never even said AP mode.. lol... Perhaps there was confusion when I said I am using a Wifi plug to restart the hubitat? That was something I added about a year ago so I could stop going back and forth to restart... Then I added a routine to Alexa so I can just say "Alexa, Restart the hubitat" - Which works, but is starting to get on the family's nerves.

I've completed the procedure for a soft reset and KNOCKS LOUDLY ON HIS WOODEN DESK it has not gone down since that. I am hoping this lasts.

No you indicated that you were using wifi

I may have read this wrong, do you mean a wifi adapter or a wifi outlet is on the hub? If I misinterpreted and it's the latter my apologies. Then I would say that you should do a soft reset. Powering down by switching off power instead of shutting down from within hubitat can corrupt the database and cause. Doing a soft reset will clean it up.

Also what do your logs say? Anything stand out? Anything in Hub Events?

Yes, the electrical outlet is what I meant.

Soft reset is done- so far, it has stayed on the network. Sometimes it's 10 minutes... sometimes it's 3 days. Hopefully the soft reset worked.

The logs have nothing special. I went to the time when the hub had last checked in- and I saw the Z-Wave Poller App logging the whole time, so I knew the hubitat/z-wave was still working. I just can't get to the web pages, Alexa can't control anything connected through the hubitat, and pings are not replied to. My only solution has been to power it off and back on again. Since I am not always at home to do that, I added a wifi plug for the outlet so I can remotely do the restart.