C-4 to C-7 Migration

I just reset my Hubitat C-4 I bought couple of years ago as I wanted to set it up in my new house. I have paired about 30 z-wave and 32 zigbee devices with it already and have just realised that there is now a newer hardware version available with improved features and better capabilities so I am considering ordering it to take advantage of it as it may not be easy to migrate in future once I have it completely setup.

I don't have many rules setup yet so I can easily redo them in the new hub but I am wondering how difficult will it be to migrate all the devices I have in the existing hub.
Any advice will be highly appreciated.

I’d definitely say the small price to pay for a new hub would be well worth it.

I recently migrated my C4 to C7 and am really glad I did it.
There are loads of ‘migration’ tips already in the forum.

2 Likes

Do a search for c-4 to c-7 (your title :wink:) and you will find numerous threads.
As for the migration, if you load your existing c4 backup onto a c7 all your rules and devices will be there.
They will not be paired though.
Zigbee is easy as you just re-pair on your c7, without deleting them, and they will work to your existing rules.
Z-wave are not as easy but Bruce has published a method for doing this which I used and does work. It needs more care though.
The main advantage of the C7 is the zwave 700 series radio which opens up these devices facilities etc.

3 Likes

I am having a couple of issues with my existing hub and hubitat support told me it could be due to a corrupted database so I am thinking of starting over as the export may carry over whatever is causing the issue.

I don't have many automations setup yet so don't have to worry about it.

In this case, what's the best way of removing and adding the devices to the new hub?

For the Z-Wave stuff...

2 Likes

Also consider repurposing your C-4 to be a Network Devices/Cloud only hub.. That way you can isolate the non-local stuff, control which devices get exposed via HubMesh AND reduce overhead on your new main hub.

1 Like

If you have a corrupt database you may want to take a backup to your PC.
Do a SOFT RESET and re-install the database you have just saved.
This will clear up any corruption of the database.

An export should clear all corruption.

3 Likes

With zigbee as I have indicated above.
With z-wave as per @erktrek's attached thread for migrating a zwave network.

1 Like

You have read my mind. That's the next question I was going to ask.

1 Like

:grinning_face_with_smiling_eyes:

It works really well. I have all my cloud/semi-cloud devices including Lutron and Flume Monitoring there as well as any groups or devices from my other hubs that I want shared via Alexa & Homebridge.

Disclaimer: I am using a C-5 not a C-4. Originally was using a C-4 but it died on me. The really good news is since there are no physical devices connected, migrating from a backup is trivial. You can also turn both Zigbee and Z-Wave off or remove the Nortek stick and repurpose that for experiments like running Home Assistant... good times.

That's a good idea. So I can have apps such as HPM and DW and any other apps I want to try first on the older hub? The older hub can access all the devices and drivers etc. on the new hub in this case?

Absolutely thanks to HubMesh... just link the devices you want the apps to control and share any C-4 devices with the other hub for your rules etc... I am using Node-RED for my rules and it's the one network app I connect to all 3 of my hubs so I can access the devices directly. I could also do the same for Homebridge but I only have a small number of devices added to it right now. If I wanted to expose more I would probably add an HB connection to each hub directly. It's a bit of a balancing act.

Notice I do have HPM running.. I have another C-4 that I donated that is running nearly the most current firmware.. I havent updated them to the absolute latest and greatest yet but it should be fine.

This gets mentioned here quite a bit. Going to look into it more. Any easy guide for starters on how to install and configure on a RPi ?

Here is an older post I did..

Download the Hubitat app