Button Controllers throwing Javascript error (Zigbee Button + Zigbee dimmer)

Hi, I just received my Hubitat Elevation. Currently running version:

I have a Zigbee Nue Dimmer and a Smartthings Zigbee button. I tried to use the Button Controllers app to adjust the dimmer by a certain amount and was presented with a Javascript error. I tried this with Nue Zigbee Dimmer and with a Virtual device dimmer, both throwing the same error. I don't seem to find a way to make this work, any thoughts would be appreciated. Here's a video capture of my error:


Unexpected Error

An unexpected error has occurred trying to load the app. Check Logs for more information.

Error: No signature of method: java.lang.Long.getAt() is applicable for argument types: (java.lang.Integer) values: [0] Possible solutions: getAt(java.lang.String), next(), putAt(java.lang.String, java.lang.Object), wait(), grep(), getClass()

I can reproduce this error (button device or dimmer device doesn't seem to matter; my guess is it's in the app). Tagging @bravenel since I believe he would be the one to investigate.

To summarize the video above, here is the error that happens:

...immediately after entering a "By this amount" value in BC 3.1 as, for example, below:

1 Like


This has been reported to staff.

1 Like

This is a known bug, fix in upcoming 2.2.3 release.

You can work-around using Rule Machine for that one button function.

1 Like

My advice would be to try the community based Advanced Button Controller app. It is an intuitive and easy to use app for buttons. Many people prefer this over the built-in button app.

Thanks for the fast replies. I'm glad to know that this a known issue and that there are plans to address it. That's great!

I ended up using the Rule Machine app as suggested which worked just fine, I'll give the Advanced Button Controller a try as well, however I'll have to learn how to install it, I'll find my way through :slight_smile: