Button Controllers bug or localized problem?

I'm running firmware 2.2.6.137 on my C7, and today for the first time I tryed to use Button Controllers. But when I try to add a new button controller I can't set the action for the button, the only option showed is to delete an action. This neither shows the drop-down menu correctly, and if I try to click in it I'm able to select it, but when I click outside the menu I get an unexpected error saying "Error: Maps with null keys can't be converted to JSON".

According to another post in the forum, t seems to indicate a driver problem, but I tried with three different buttons of different brands, each one using a different driver and obtaining the same result.

I know I may use RM to achieve the same effects I want, but I would like to know if the app is really bugged. If affirmative, wouldn't be interesting take it out at once?

Any tips are welcome, thanks in advance.

Same here - just tried to use the Button Controller app for the first time today and could add a button action. Went to use the Simple Rule app instead which worked just fine.

As I mentioned in that other thread, did you verify that your device is reporting "numberOfButtons" under "Current States" on the device page? I'm guessing at least one of your devices is unless you're having really bad luck, but the Buitton Controller UI definitely won't work without it. (If you don't have this value, there are some tricks to get it set correctly, but "Configure" or "Save Preferences" may work, depending on how the driver was written.)

If that's not the problem, then perhaps try creating a new Button Controller instance and see if that new app has the same problem. If so, staff may have to comment with what (app state, logs, etc.) would be most helpful for them to track down the problem.

2 Likes

Thanks @bertabcd1234, but the attribute is correctly showed under "Current States". I checked carefully, two of the drivers really don't show it, but the driver I'm using in this case is the Samsung Zigbee Button, that exhibits the required info.

This isn't quite clear to me: can I assume that these are devices you aren't using in this Button Controller app? If they are being used, it is a problem, even if other devices using the same driver do show the "numberOfButtons" attribute.

If that's all good, how about the suggestion to create a new Button Controller? (You don't have to uninstall the "parent" app, just go into it and make a new "child" app like you would normally--basically, trying to rule out the possibility that something went wrong with just your existing child app.)

Thanks, @bertabcd1234, include another instance of the child app did the trick! But the question remains: why it didn't work directly?

Thanks for the help!

That I don't know. :slight_smile: It's possible something got corrupted in the original attempt. If you can find a way to reproduce the problem, staff would probably be interested to know so they can fix the problem. Otherwise, maybe just one of those odd things...

1 Like

Download the Hubitat app