Button Controller does not trigger actions

Just updated to 2.3.1.137.

Working with a Aeon Wallmote Quad that controls my dinning room lights. I wanted to change the actions that were previously programmed so I deleted all the child apps in the Button Controller so I could start fresh.

Created an action in Button Controller for button 2 pushed.

When I click the "Run Actions" button the action executes as designed.

Also, when I press button 2 on the Wallmote, the log shows that the button was pressed. The device "Current State" updates to show button 2 was pressed. However, no actions are triggered.

So then I removed the entire device and performed a factory reset on the Wallmote.

I added the device back and performed the steps above to create an action for when button 2 is pressed. Same result, if I press "Run Actions" then it works. But if I press the button on the Wallmote I get log entries that the button was pressed, but no actions run.

As a last try, I took another Wallmote I have that had a button unconfigured from another room. I configured that button and it still doesn't trigger the actions.

The Wallmote in the bedroom is untouched for weeks and is still working as it always has, It seems that only new button actions in the Button Controller are not triggering the actions to run.

I'm at a loss for what to try next.

The best way to get fast troubleshooting tips is if you could enable the app logging, then share a screenshot of the Logs while pressing the buttons. Many of the apps have one or more settings for logging. In the Button Controller, they look like this:

Please enable those then share Logs for both the app and button device.

I had something similar happen with one of my Button Rules, where after I edited the Button Rule it didn't seem to trigger anymore. I removed the rule and re-added it and then it seemed to work for me though, so not sure if there is something more going on there. If you can get a log for Bobby to look at, then maybe they can reproduce the issue.

Besides the above, have you tried just going into the "grandchild app" (the one for your specific button event, should display as an app of type "Button Rule" in list view) and hitting "Done with Button Rule"? This should re-create the subscriptions, which could be one reason it's not working.

You could verify that before and after, too: go into the "App Status" page (gear icon next to this grandchild app, or the similar icon in the top right if you're in the app itself) and look under "Event Subscriptions." In your case, it sounds like you should see at least one subscription for a "pushed.2" event. The "Done" thing above, again, might re-create these if that's all that's missing.

But logs, or perhaps the lack thereof if enabled, would be great, too. :smiley:

It's not busted for me atm, so can't demonstrate, but I seem to recall the event subscription said something like pushed.null which might explain why the event subscription ain't picking up the trigger.

Here we go @bobbyD .

I edited one of the Button Rules, deleted the existing Actions and added a new conditional rule and then saved the Button Rule, this resulted in a busted pushed.null Event Subscription. See below.

The existing rule just toggled a switch, I removed that action and added the simple conditional rule below.
image

EDIT:

If I delete the Button Rule altogether, go back into the Button Controller and re-add the pushed action and create the rule exactly as is from scatch, it then works fine and the event subscription is there.

So this issue seems to occur when you go into a rule and delete an existing action. Editing the values of an existing action doesn't seem to break it, only when you delete one.

3 Likes

I was about to say that I usually just edit the actions rather than delete. I have a distant memory of messing up a button rule by deleting a child.

Odd, is this an older version of Button Controller instance or the newer 5.1? You can see the version on the Apps page.

Update, never mind, prior version didn't have conditional rule.

Definitely 5.1. Don't have any older versions installed.

1 Like

Yeah, not enough coffee yet. Prior version didn't have conditional rule.

Aye that's right. It's quite a weird little bug though, I'm unsure if my experience is exactly as the OP but I can definitely get the rule to not trigger if I delete an existing action and change the rules.

1 Like

Yup, it is. I had a button controller 3.1 rule that stopped working for the push event, the other day, but didn't spend much time figuring out why. I just deleted and recreated in 5.1. Will try to replicate.

I cannot replicate. Did you have conditional rule when you deleted the action?

UPDATE: never mind. I was able to replicate. Expect fix in next release.

1 Like

Goodo. Thanks for investigating. Hopefully whatever is wrong will correct for the OP as well.

2 Likes

Thank you for all the thought work while I was sleeping. Very kind of you.

It looks like this is my issue.

FWIW - I did enable the Tirggers and Actions logging. Nothing is written to the log when I press button 2. There are log events when I use the Run Actions button online. The only log entry made when I push button 2 is that button 2 was pushed and then nothing further.

1 Like

Thank you for the fix in the latest version.

Download the Hubitat app