Button Controller 3.1 - No button actions showed

I've looked at similar threads but don't see a duplicate so here goes. I've tried both Edge & Chrome and Safari through an IPAD, all exhibit the same issue.

When attempting to use the app with the samsung zigbee button driver it simply won't display any options. There is no "prefill" button, and the actions dropdown is blank.

I should add, that I can fool the app, by first selecting a different device such as a Zen21 gen 3+, and it works dandy. I can then swap the button controlling device and it continues to function fine so I've got a workaround, but it still "bugs" me :slight_smile:

Bug? Or user error?

1 Like

I am having the same issue with a Sengled dimmer

Have you tried just going to the device page (for the Sengled dimmer) and hitting the "Save" button under the device preferences? My guess is that you don't see "numberOfButtons" under "Current States" towards the top of the page, which you need to make this work. How this gets populated depends on the driver but should happen automatically. The above or hitting "Configure," if present, are good guesses if not, or you can try the (way above) workaround like switching to a Pico driver temporarily just to set the preference it exposes.

I had this happen with a Lightify 4-button switch back before I moved all of my end devices to their own hub. It was not getting completely configured due to mesh issues and the configuration having to send a lot of information. It seems odd for it to happen with a Samsung button though, because even when my mesh was a terrible mess my Samsung buttons worked fine. You’re probably right though.

Hitting the save button was the solution. Thanks!