Bug with HubMesh - Many phantom events

I moved my Samsung TV (connected via HubConnect) to my secondary Hub because I poll it frequently and I didn't want it slowing down my primary Hub. I then connected the TV via HubMesh to my primary Hub. I have a bunch of Rule Machine triggers and actions on my primary hub based on events that happen on the TV (inputs changing, switch changing, tv channel name changing).

For some reason, the TV has a ton more events on the primary hub (connected via HubMesh) than on the hub it's actually connected to. Seems HubConnect is generating a ton of fake events. Because of this, I'm getting phantom triggers every 2 mins. Below are the events from each of the hub:

EVENTS FROM HUB TV IS CONNECTED TO:

EVENTS FROM PRIMARY HUB TV IS CONNECTED TO VIA HUBMESH

Sorry, should have read the other post more. Just noticed that it's the same issue mentioned here:

Bug with HubMesh - Lutron Pico Devices - Hubitat

This isn’t happening with every device. I have setup a few on my dev hub and so far button devices are the only problem devices I have found but your situation is similar. Tagging @gopher.ny for his awareness of this device issue as well.

Buttons, remotes, presence, and contacts have this issue for me.

1 Like

I don’t have any presence sensors but will test with a few contacts too. Thanks for mentioning these.

I am trying to validate hub mesh can handle my 3 hub to 1 coordinator setup with 240 devices. Might wait a bit before tackling given these issues.

1 Like

I tried 5 to 1 coordinator with 280 devices - it kind of worked, but somethings never fired. Also the coordinator hub was sooooooooo slow.

I was doing 3-to-1 coordinator when I was using HubConnect.

When I switched over to Hub Mesh, I got away from the "central hub" concept - instead, I designated a "specialty" for each Hub, like this:

0 - Lutron
1 - Zigbee
2 - Konnected, Bond, Sonos
3 - Presence, vacation/holiday, testing

Using RM's new export/import capability, I moved all my rules to whichever Hub contained the majority of referenced devices, and then used Hub Mesh to "cross" whichever devices needed to be referenced off-Hub.

It's all working 100% here, so far... <knocks on wood>

2 Likes

2.2.4.147 should have phantom events taken care of. Please let me know if it didn't,
Also, you can set device refresh frequency at the bottom of the hub mesh page. Just don't set it to "never" for now.

1 Like

Bummer! My coordinator C5 hub is slow now with hubconnect and was hoping for better performance with mesh.

I was having this issue with a presence sensor. Every 2 mins it reported its presence. Only noticed it today.
Rebooted both hubs and it was still happening.
Just updated to 2.2.4.147 and it has stopped.
Looking good so far. :+1: :crossed_fingers:

3 Likes

That was fast. Thanks. Updating now. Will update on results

@gopher.ny I decided to spend some time sharing devices from my 3 "prod" hubs with my dev hub to validate things before I tear apart my hubconnect coordinator. I noticed that my Qubino relay components don't show up in the list of "share local devices". These use the stock "generic component metering switch" driver:

I am also using Inovelli's "Inovelli Dimmer Red Series LZW31-SN" driver and it has a child "Switch Child Device" that doesn't show up in the list either. The parent device did but not the child.

Same situation for my Aeotec Water Sensor 6 and its child "Generic Component Water Sensor" devices.

Long story short it appears there is a bug with child component devices not showing up in the list of devices to share with other hubs. Can you please validate this is an issue or working as designed? If working as designed could you please consider child component devices for a future release?

If you share the parent, it should propagate its children dynamically. Say, parent adds another child device on the fly, it will show on destination hub during next full device refresh.

There's no way to share child device on its own right now, but we're listening for the feedback. If there's demand, it will happen.

Something weird is now happening... HubMesh just overwrote an attribute (tvChannelName) on the actual device.

The left is the hubmesh hub while the right is the hub with the actual device.

I would have to look at the specific device and driver. True, HubMesh can "think" that something switched on the destination hub and update the source hub, although I don't know why it would in this particular scenario.

If hub mesh switches TV channels, please stop sharing it for now. I'll see what I can find, but it will take time. Can't have it mess with the TV in the meantime.

I should clarify. It changed the value of the "TV Channel Name" on the HubMesh hub but not on the actual hub the TV is connected to. So essentially, both hubs went out of sync.

I wonder if it has something to do with the event that occurred 45s earlier getting re-sent to the HubMesh hub.

Also, for your troubleshooting, please note that I'm using TCP (I have a mesh network router).

Interestingly, HubMesh then corrected itself 12 mins later (Note the event at 02:06:52):

@gopher.ny OK thank you for the clarification. So this worked for the Aeotec Water Sensor 6 and a few other devices but there is still an issue with the Qubino device. In the device list it doesn't show children:

But if you open the device and scroll to the bottom they do show up:

While I have you, could we make the "on X/hub name" device name suffix be settable preference? Given I am sharing 240 devices and plan to have dashboards be on my coordinator hub, I would prefer not to see this extra text in the device name. I would rather the label match the primary hub device label. Just to be clear in my screenshot above I would rather the device be named "Den Overhead Lights" and scratch the "on Kilmory Zigbee" suffix. I realized I can add a label to all my devices, but doing that on 240 devices is going to be a pain in the arse.

Thanks!

1 Like

after updating my hubs I had a few phantom events initially, then everything has quieted down. i’m assuming that after the first sync the phantom events stopped.

@gopher.ny I still have this issue occurring. In the below screenshot, Hub mesh came up with its own random, fake event claiming that inputSource was changed to HDMI2 (even though it wasn't). That then triggered my rule to start my Harmony activity which then changed my actual TV's input to HDMI2.

Please when do you expect to have it fixed?

Download the Hubitat app