[BUG] Mode Manager

When setting specific time in mode manager it doesn’t save what I enter. I enter the time hit done and then it doesn’t show that it is set.

Does the same based on sunrise/sunset works as expected and shows it being set.

Ok no problem.

BTW - what browser are you using for testing? I currently was doing this in Firefox (latest). Let me try with Chrome.

Sometimes, it appears as if it didn’t save some value you’ve entered. But, if you go back into that page, you will discover that it is set, and when you hit Done again, it shows as being set. This is some funky browser behavior that we are familiar with, and we will have an improvement for in the future.

In general, after you enter something like a time or a number or text, hit Enter before you hit Done.

1 Like

Found the problem - on my end atleast.

In Firefox for the time it is setup like this

( --:–:-- )

I can set the hour and minute but not what I thought was seconds. I use 24 hour time for everything anyways. So I entered 00:00 and it auto changed to 12:00:-- in Firefox and I hit done.

It didn’t save because it wasn’t valid.

When I opened in Chrome the entry box was the same. EXCEPT that on the right hand side was the up/down arrow. So… I pushed it and saw that what I thought was the seconds in the time was the AM/PM. I selected the appropriate one for the time hit done. Then it saved.

This is a browser issue.


I have to put a non-zero vale in the fields and save. Then after that I can change to zero. But, I cannot select PM. It is always AM after changing and saving.

To add to this bug, if you press enter like suggested, i am redirected to a screen that reads Mode Manager and a done button (nothing else) and now I cannot manage that mode rule. (In my case, time of day)

I experienced this the other day on several browsers on both iOS and Windows.

After several attempts I got it to save. Regardless I was having a challenge saving it.

What browser are you using on what platform? There was a problem with Safari on MacOS.

I had trouble this morning using Safari on my iPad. I had to enter 00 as hour, any number other than 00 in minute to get it to save. Once set I could then edit. Key is getting it set with a value first.

I tried with iOS Safari, MacOS Safari. Trying now on chrome browser and Interestingly, on Safari, the time is presented as two text boxes (hour and minutes) and a pull-down (am/pm), but on Chrome it is a singe text box with the notation of --:-- – which does work just fine.

Safari on MacOS did not implement HTML 5, so time input is messed up. We catch that it’s Safari, and put up the two text boxes instead. Chrome and other browsers work well. We will look again at the Safari inputs, and why they aren’t working right.

This mightbbe helpful. If i use the Develop menu option if safari to set the user agent advertisement as Google Chrome MacOS, then i do get the chrome style time input, except instead of the format being —:— — (12hr format) it is —:— in 24h format, and it works just fine. And if I enter into Mode Manager as a new entry, then it appears to be a blank text box, but it does work so long as it is entered in 24hr format. Type it in wrong, and the Mode Manager gets corrupted and wont load.

It appears I have ben caught by this same "gotcha".

I was trying to use Mode Manager on Mac OS Safari to set up a mode change at a certain time, and after entering in [6] : [00] [AM], on clicking "Done" I was presented with a blank menu:

Clicking "Done" just takes me back to the first Mode Manager menu, with no evidence the time I entered was saved.

So I went to Rule Machine, started setting up a Trigger rule to make the mode change, was setting up the trigger at a certain time, and also got a blank menu after clicking "Done":

In this case, I click "Done", get that same blank menu with the Done button, click "Done" again, and a third blank menu with no way out except the << App List link.

Finding this thread I now know that this is because there is probably still an issue with using the Safari browser. Based on my experience, I have a question and a suggestion:

Question: Do I need to be concerned about incomplete "orphaned" child apps? I have encountered this before when I inadvertently clicked << App List before finishing a rule, and the only way to find that rule to delete it is to go to the device details of a device it was associated with, because it isn't listed as a child in the main Apps list page. In this case, I started a rule that wasn't associated with any devices, and I don't know if it's actually been saved somewhere I just can't view. Is there? Same thing for the Mode Manager, since I made several attempts at that before giving up.

Suggestion: Please list Safari as an unsupported browser for the time being, or list Chrome / Firefox as recommended browsers. I checked the main website, on the forums here, and the Support Center site, and there's nothing about supported or recommended browsers.

Thanks for the details. We have found a bug in our code specifically for safari and time inputs. The bug has been fixed internally and should be available in the next update.

In the meantime, the best I can come up with is to use a different browser for time inputs such as Chrome or Firefox as this bug specifically effects Safari on Macs only.

As for your question regarding Orphaned child apps, there is no reason to be concerned over them as they will be cleaned up internally by a routine that handles incomplete apps that aren’t installed.


Thanks for clarifying the orphaned app issue @patrick. I was being extra careful to delete these every time I messed up clicked out of the App during configuration. How often is this automatic scavenging scheduled?

I am having this same problem with Rule Machine. It looks like I have apps on multiple devices that no longer exist.

I’m having problems with Mode manager in Safari and in Chrome. I’m connecting with my phone over VPN.

I have four modes (Away, Home Day, Home Night, and Sleeping in that order). I’m trying to set mode based on presence, I am using a virtual presence sensor. I am able to select the presense sensors for away and for sleeping, but not for the Home Day or night modes. I am able to set the mode based on time for Home Day and Home Night. When I select mode based on presnce I get a prompt for the presence sensors, I select the sensors, and then Nothing happens. I’ve rebooted the hub, and I am on the current firmware.

I’ve also uninstalled mode manager and tried again. Any suggestions?

Same from home computer using Chrome browser.

Can you post a screen shot?

Also, post a screen shot for the virtual presence sensor that you cannot select, device details page.

Sure, here's my list. I can select any and click ok, but just sends me back to the menu with nothing selected

I will say when I first set this up I tried to delete some of the built in modes, but received a 500 error, so I assumed that was a no go. :slight_smile: